Bug Hunting Session
Bug 116246 - Dirac Notation is not available in LibreOffice Math
Summary: Dirac Notation is not available in LibreOffice Math
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
5.3.6.1 release
Hardware: x86 (IA32) All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Formula-Editor
  Show dependency treegraph
 
Reported: 2018-03-06 19:30 UTC by chinwoon_koh
Modified: 2018-03-11 16:28 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Exemple imported from Egation 3.0 (11.52 KB, application/vnd.oasis.opendocument.text)
2018-03-07 16:30 UTC, Jacques Guilleron
Details

Note You need to log in before you can comment on or make changes to this bug.
Description chinwoon_koh 2018-03-06 19:30:04 UTC
Description:
I searched in LibreOffice Math to enter Bra and Ket Vectors under the brackets section but only the inner product of the Dirac notation is provided. There is also no outer product notation as well.

Steps to Reproduce:
1.Launch LibreOffice Math
2.Select Brackets
3.

Actual Results:  
only <|> and <> bracket can be seen

Expected Results:
there should be brackets <| , |> and |><| in the software


Reproducible: Couldn't Reproduce


User Profile Reset: No



Additional Info:
It will be good to cater for the all the symbols that are used in maths
They can be found here: https://en.wikipedia.org/wiki/List_of_mathematical_symbols#Symbols_based_on_Latin_letters


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 V Stuart Foote 2018-03-06 21:32:29 UTC
Not clear we need predefined paired brackets. Beyond what scalable StarMathML markup provides; e.g.:

left langle left lline <?> right rline right rangle
newline
left rangle left lline  <?>  right rline right langle 
newline
left lline left rangle  <?>  right langle right rline

But OK I guess.

@Regina?
Comment 2 Jacques Guilleron 2018-03-07 16:30:22 UTC
Created attachment 140445 [details]
Exemple imported from Egation 3.0

Hi,

With this example imported from Eguation 3.0, it seems to be no issue to write and reproduce it the same way into LO.
Comment 3 Jean-Baptiste Faure 2018-03-11 16:28:52 UTC
I agree with Jacques in comment #2. No problem to reproduce Dirac notation (Ket & Bra). So closing as WorksForMe.

Best regards. JBF