Bug 116257 - Find & Replace wrong results
Summary: Find & Replace wrong results
Status: RESOLVED DUPLICATE of bug 116242
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.2.1 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-07 08:37 UTC by badrian
Modified: 2018-03-10 10:48 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
the bug screenshot (63.13 KB, image/png)
2018-03-07 08:39 UTC, badrian
Details
test file (12.43 KB, application/vnd.oasis.opendocument.text)
2018-03-07 08:40 UTC, badrian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description badrian 2018-03-07 08:37:09 UTC
Description:
My Romanian language uses special characters like s with comma underneath (ș), t with comma underneath (ț), etc. If I use one of these special characters for Find All, it highlights and the corresponding non-special characters, i.e. s, t.

Steps to Reproduce:
1. Generate a text with language specific characters (e.g. e breve - é, ă, etc), in addition to basic characters (e, a, etc).
2. Run Find & Replace matched case, Find All, search for that specific character (e.g. é)
3. There will be highlighted in the text and non specific characters, e.g. both é and e.

Actual Results:  
All characters related to the basic character, i.e. é and e, are highlighted.

Expected Results:
Only the character in the search field should be highlighted in the text.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 badrian 2018-03-07 08:39:00 UTC
Created attachment 140412 [details]
the bug screenshot
Comment 2 badrian 2018-03-07 08:40:40 UTC
Created attachment 140413 [details]
test file
Comment 3 Jacques Guilleron 2018-03-07 23:58:39 UTC
Hi Badrian,

Before to search your special character, in Find & Replace, open Other options by clicking the + in front of Other options, and tick Diacritic-sensitive.
Does it work this way?
Comment 4 badrian 2018-03-08 00:42:01 UTC
(In reply to Jacques Guilleron from comment #3)
> Hi Badrian,
> 
> Before to search your special character, in Find & Replace, open Other
> options by clicking the + in front of Other options, and tick
> Diacritic-sensitive.
> Does it work this way?

Hi Jacques,
There is no such option in 6.0.2.1 (x64) both in Ubuntu and Windows (virtual machine downloaded from LibreOffice site, today). I have checked this before submitting the bug.
Comment 5 Jacques Guilleron 2018-03-08 09:23:01 UTC
Hi Badrian,

Open Tools > Options > Language Settings > Languages
and tick Complex text layout, next OK.
Now, you will find Diacritic-sensitive feature at the end of Options in Find and Replace. Is it right?
Comment 6 badrian 2018-03-08 09:56:20 UTC
(In reply to Jacques Guilleron from comment #5)
> Hi Badrian,
> 
> Open Tools > Options > Language Settings > Languages
> and tick Complex text layout, next OK.
> Now, you will find Diacritic-sensitive feature at the end of Options in Find
> and Replace. Is it right?

Hi Jacques,

That solved the problem. 
However, this feature is very new and seems undocumented, at least for me, taking into account that in ver 5 was not necessary. 
May be it should be enabled by default, because it is very hidden without any obvious connection with the Find&Search window. Also, in the Complex text layout should be NONE by default and not Hindi, since other bunch of languages is not part of the list.
Anyhow, thank you very much for your time and help!
Comment 7 Xisco Faulí 2018-03-08 13:20:35 UTC
(In reply to badrian from comment #6)
> (In reply to Jacques Guilleron from comment #5)
> > Hi Badrian,
> > 
> > Open Tools > Options > Language Settings > Languages
> > and tick Complex text layout, next OK.
> > Now, you will find Diacritic-sensitive feature at the end of Options in Find
> > and Replace. Is it right?
> 
> Hi Jacques,
> 
> That solved the problem. 
> However, this feature is very new and seems undocumented, at least for me,
> taking into account that in ver 5 was not necessary. 
> May be it should be enabled by default, because it is very hidden without
> any obvious connection with the Find&Search window. Also, in the Complex
> text layout should be NONE by default and not Hindi, since other bunch of
> languages is not part of the list.
> Anyhow, thank you very much for your time and help!

Putting back to UNCONFIRMED

@Olivier, do you know if this new feature is documented ?
Comment 8 Jacques Guilleron 2018-03-09 09:29:59 UTC
I verified from 
LO 4.4.7.2 
I confirm there was no such need until
LO 6.0.0.0.beta1 Identificator construire: 97471ab4eb4db4c487195658631696bb3238656c
Fire CPU: 2; OS: Windows 6.1; Redare UI: implicit; 
Setări regionale: ro-RO (fr_FR); Calc: CL
The only change is this Diacritic-sensirive option
previously named Ignore diacritics but without effect on Search.
Comment 9 badrian 2018-03-09 13:07:09 UTC
(In reply to Jacques Guilleron from comment #8)
> I verified from 
> LO 4.4.7.2 
> I confirm there was no such need until
> LO 6.0.0.0.beta1 Identificator construire:
> 97471ab4eb4db4c487195658631696bb3238656c
> Fire CPU: 2; OS: Windows 6.1; Redare UI: implicit; 
> Setări regionale: ro-RO (fr_FR); Calc: CL
> The only change is this Diacritic-sensirive option
> previously named Ignore diacritics but without effect on Search.

So, before ver 6 the setting in LO was diacritics enabled by default and a switch to Ignore diacritics, now it's the opposite: diacritics disabled by default and a switch to enable them (Diacritics sensitive). I liked as was before ver 6.
Comment 10 Aron Budea 2018-03-10 06:52:43 UTC
I believe this has been fixed in bug 116242.

*** This bug has been marked as a duplicate of bug 116242 ***
Comment 11 Jacques Guilleron 2018-03-10 10:48:02 UTC
Yes Aron,

Works as before LO 6 with Master
LO : 6.1.0.0.alpha0+ Build ID: 0d1479cbd442c3ec3bdd20333c341ea24dcca21e
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-03-10_01:47:26
Locale: ro-RO (fr_FR); Calc: CL