Bug Hunting Session
Bug 116289 - Renaming of Shapes and Text Frames is not Possible with Context Menu
Summary: Renaming of Shapes and Text Frames is not Possible with Context Menu
Status: RESOLVED DUPLICATE of bug 101193
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2 all versions
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, needsUXEval, regression
Depends on:
Blocks: Context-Menu
  Show dependency treegraph
 
Reported: 2018-03-08 10:37 UTC by Harald Koester
Modified: 2018-03-13 19:18 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of customize dialog (90.18 KB, image/jpeg)
2018-03-13 18:53 UTC, Dieter Praas
Details
clip of the Customize dialog for context menu -- Name control (24.43 KB, image/png)
2018-03-13 19:01 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2018-03-08 10:37:16 UTC
Steps to Reproduce:

[1] Create new text document and display Navigator.
[2] Insert a shape e. g. a rectangle.
[3] Insert an image.
[4] Right click on inserted image > Properties… > Tab Options. The name of the image is displayed  in the dialogue. 
[5] Insert new name. Then OK. The new name is displayed in the Navigator. This is OK.
[6] Right click on inserted shape. The context menu is displayed but there is no entry in order to rename the shape. Expected: Entry in order to rename the shape like it is possible with images.

It's also not possible to rename Text Frames with the context menu.

Works for me with version 5.1.6. Hence regression.
Comment 1 Dieter Praas 2018-03-08 10:47:48 UTC
I confirm it with

Version: 5.4.6.1 (x64)
Build-ID: 7d6c666f03cf1f0a0c2c51a17c0f67a8d5a8012b
CPU-Threads: 4; BS: Windows 6.19; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group
Comment 2 Xisco Faulí 2018-03-08 12:51:29 UTC
Regression introduced by:

author	Maxim Monastirsky <momonasmon@gmail.com>	2016-01-19 00:37:47 +0200
committer	Maxim Monastirsky <momonasmon@gmail.com>	2016-01-19 02:05:01 +0200
commit	447c313586e9b36acff393feae15f5e1b63861ae (patch)
tree	2cbfc56c4aa843351261731e5ac43d1f59104650
parent	8cd6dd0a35b1c531ddb5010a3dea84f91f2ffb40 (diff)
tdf#93837 Convert Writer context menus to xml

Bisected with: bibisect-linux-64-5.2

Adding Cc: to Maxim Monastirsky
Comment 3 Maxim Monastirsky 2018-03-08 13:23:39 UTC
(In reply to Xisco Faulí from comment #2)
All the changes that were made to context menus were proposed by our design experts, I did nothing on my own. You really should talk to them.
Comment 4 Xisco Faulí 2018-03-08 13:26:17 UTC
(In reply to Maxim Monastirsky from comment #3)
> (In reply to Xisco Faulí from comment #2)
> All the changes that were made to context menus were proposed by our design
> experts, I did nothing on my own. You really should talk to them.

Ok, Thanks for letting me know.
Closing a RESOLVED NOTABUG then...
Comment 5 Dieter Praas 2018-03-08 14:15:27 UTC
Although it was a decision by the design team, I don't understand it. I can't find a possibility to rename a shape. If you have a document wih a lot of shapes, it might be useful to name them instead of using Shape1, Shape2, ....
So I would say that's a proposal for an enhancement.
Comment 6 Xisco Faulí 2018-03-08 14:20:09 UTC
(In reply to Dieter Praas from comment #5)
> Although it was a decision by the design team, I don't understand it. I
> can't find a possibility to rename a shape. If you have a document wih a lot
> of shapes, it might be useful to name them instead of using Shape1, Shape2,
> ....
> So I would say that's a proposal for an enhancement.

Ok, I agree with you.
Let add the UX team here...
Comment 7 Thomas Lendo 2018-03-12 19:52:16 UTC
Jay was the driving force behind menu and context menu changes in the last years. I assume it was deleted as it is a not so highly used feature.

Everyone can customize the context menus and add the renaming command by himself/herself.
Comment 8 V Stuart Foote 2018-03-12 20:21:01 UTC
You can add the Name & Description fields back to the context menu if desired. Removed by default. Duplicate of bug 101193, or bug 96405

Longer term design is implementation of a consolidated dialog for Object-properties (bug 96355)

*** This bug has been marked as a duplicate of bug 101193 ***
Comment 9 Dieter Praas 2018-03-13 18:52:15 UTC
> Everyone can customize the context menus and add the renaming command by
> himself/herself.

Couldn't find the rename command within the customize dialog.
Comment 10 Dieter Praas 2018-03-13 18:53:04 UTC
Created attachment 140618 [details]
Screenshot of customize dialog
Comment 11 V Stuart Foote 2018-03-13 19:01:31 UTC
Created attachment 140619 [details]
clip of the Customize dialog for context menu -- Name control

(In reply to Dieter Praas from comment #9)
> > Everyone can customize the context menus and add the renaming command by
> > himself/herself.
> 
> Couldn't find the rename command within the customize dialog.

The control to add is "Name" (as localized). In use it will shows the default name. And if a name had been assigned, the Name... dialog will allow it to be changed.
Comment 12 Dieter Praas 2018-03-13 19:18:14 UTC
It works. Thank you!