Download it now!
Bug 116294 - Impress 6 always crashes when we want to minimize the presentation (KDE4)
Summary: Impress 6 always crashes when we want to minimize the presentation (KDE4)
Status: RESOLVED DUPLICATE of bug 117466
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.0.1.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2018-03-08 15:37 UTC by Ysabeau
Modified: 2018-05-28 10:51 UTC (History)
4 users (show)

See Also:
Crash report or crash signature: ["libc-2.22.so"]


Attachments
gdb backtrace (39.99 KB, text/plain)
2018-03-09 16:14 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ysabeau 2018-03-08 15:37:13 UTC
Description:
When you click on Tools > Reduce (or resize?) the presentation (in French Réduire la présentation), Impress 6 crashes.

Steps to Reproduce:
1.Make a presentation
2.Go to Tools and click on Reduce the presentation to reduce the size of the file.


Actual Results:  
It always crashes, with any file.

Expected Results:
Impress should do the job without crashing.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
crashreport.libreoffice.org/stats/crash_details/703e6398-0890-433b-ae4f-648c8e91ec18

I see that with Mageia6 (KDE5) but it has also been reported for Windows 7. I believe it can be reproduced for any OS and it appears in LibreOffice 6

Version: 6.0.2.1
Build ID: f7f06a8f319e4b62f9bc5095aa112a65d2f3ac89
Threads CPU : 4; OS : Linux 4.14; UI Render : par défaut; VCL: kde4; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Xisco Faulí 2018-03-08 15:56:02 UTC Comment hidden (obsolete)
Comment 2 Ysabeau 2018-03-08 16:07:42 UTC
Please, note that when your read "User Profile Reset: Yes" it means that YES the profile has been reseted.

Second, I found the exact name of the feature "Minimize presentation".
Comment 3 Xisco Faulí 2018-03-08 16:09:11 UTC
Could you please paste the info from Help - about LibreOffice ?
Comment 4 Xisco Faulí 2018-03-08 16:09:30 UTC
OTOH, does it happen with a particular file or with all ?
Comment 5 Ysabeau 2018-03-08 16:14:16 UTC
Can you read my report please?

Always means always, right? and not for a particular file.

The infos you ask are in the first post I wrote.

And sorry for the bad name of the feature, I repeat it is Minimize presentation.
Comment 6 joram86 2018-03-08 16:18:31 UTC
same problem with Windows 7 and a portable
LibreOffice at home (x86) and at work (x64)
same problem in safemode
Comment 7 Xisco Faulí 2018-03-08 17:58:15 UTC
Reproduced in

Versión: 6.0.1.1
Id. de compilación: 60bfb1526849283ce2491346ed2aa51c465abfe6
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group

but not in

Version: 6.1.0.0.alpha0+
Build ID: d6b33e49a5e9c51827eda9c5ba16d8daeb27e8af
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-03-07_23:26:53
Locale: es-ES (es_ES); Calc: group

I would say a dupe of bug 116147

*** This bug has been marked as a duplicate of bug 116147 ***
Comment 8 Xisco Faulí 2018-03-08 17:58:43 UTC
It will be fixed in LibreOffice 6.0.3
Comment 9 Ysabeau 2018-03-09 11:32:13 UTC
(In reply to Xisco Faulí from comment #7)

> I would say a dupe of bug 116147
> 
> *** This bug has been marked as a duplicate of bug 116147 ***

I just can't see why you think it is a duplicate of bug 116174 that is rather different... not the same features are impacted.
Comment 10 Xisco Faulí 2018-03-09 16:14:44 UTC
Created attachment 140512 [details]
gdb backtrace
Comment 11 Xisco Faulí 2018-03-09 16:15:27 UTC
(In reply to Ysabeau from comment #9)
> (In reply to Xisco Faulí from comment #7)
> 
> > I would say a dupe of bug 116147
> > 
> > *** This bug has been marked as a duplicate of bug 116147 ***
> 
> I just can't see why you think it is a duplicate of bug 116174 that is
> rather different... not the same features are impacted.

The backtrace is the same in here and in https://bugs.documentfoundation.org/show_bug.cgi?id=116147#c7

*** This bug has been marked as a duplicate of bug 116147 ***
Comment 12 Pedro Neves 2018-05-07 23:00:14 UTC
Hi:

It's still present in version 6.0.3.2 (Arch Linux)
Comment 13 Ysabeau 2018-05-10 12:29:06 UTC
Yes still in:

Version: 6.0.3.2
Build ID: 8f48d515416608e3a835360314dac7e47fd0b821
Threads CPU : 4; OS : Linux 4.14; UI Render : par défaut; VCL: kde4; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group

And in:

Version: 6.1.0.0.alpha1
Build ID: cb47f0d320994e001bc38dc2ee9b7d957b15e6ab
Threads CPU : 4; OS : Linux 4.14; UI Render : par défaut; VCL: kde4; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group
Comment 14 Ysabeau 2018-05-10 13:30:15 UTC

Still in 6.0.4.2 for Linux

Version: 6.0.4.2
Build ID: 9b0d9b32d5dcda91d2f1a96dc04c645c450872bf
Threads CPU : 4; OS : Linux 4.14; UI Render : par défaut; VCL: kde4; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group

And yes with a new profile (hence this is not my profile that is rotten). And yes again it is always also for 6.0.3.2 and for 6.1.0.0.alpha1.
Comment 15 Xisco Faulí 2018-05-28 10:47:30 UTC
Reproduced in

Version: 6.0.4.2
Build ID: 9b0d9b32d5dcda91d2f1a96dc04c645c450872bf
CPU threads: 1; OS: Linux 4.13; UI render: default; VCL: kde4; 
Locale: en-US (en_US.UTF-8); Calc: group

but not in

Version: 6.0.4.2
Build ID: 9b0d9b32d5dcda91d2f1a96dc04c645c450872bf
CPU threads: 1; OS: Linux 4.13; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group

when using SAL_USE_VCLPLUGIN=gtk, thus KDE4 only. The crash happens when clicking the Finish button and the open dialog should be open.
Comment 16 Xisco Faulí 2018-05-28 10:48:58 UTC
*** Bug 117466 has been marked as a duplicate of this bug. ***
Comment 17 Xisco Faulí 2018-05-28 10:51:56 UTC
Closing as dupe of bug 117466

*** This bug has been marked as a duplicate of bug 117466 ***