Bug 116297 - Remove table tooltips
Summary: Remove table tooltips
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: low enhancement
Assignee: Heiko Tietze
URL:
Whiteboard: target:6.1.0
Keywords:
Depends on:
Blocks: Tooltip
  Show dependency treegraph
 
Reported: 2018-03-08 18:33 UTC by Alan
Modified: 2018-04-09 14:28 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Tooltips hinding text (96.10 KB, image/png)
2018-03-08 18:34 UTC, Alan
Details
semi-transparent tooltip (42.76 KB, image/png)
2018-03-21 02:18 UTC, csongor
Details
semi-transparent tooltip - GIMP (372.28 KB, image/x-xcf)
2018-03-21 02:18 UTC, csongor
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alan 2018-03-08 18:33:51 UTC
Description:
When a table is made in Writer the tooltips for "Adjust table row" and "Adjust table column" constantly pop up and hide the text. I need to highlight certain cells in the course of my work in tables with many rows and the tooltips hide what I need to see.
There should be an option to turn tooltips off for tables in Writer, either in the expert configuration or in the otions gui.


Steps to Reproduce:
1.Make a table with text in the cells in Writer
2.hover your mouse over almost any part of the table
3.tooltips appear hiding the text

Actual Results:  
Tooltips hide the text

Expected Results:
Tooltips should be able to be turned off for tables in Writer


Reproducible: Always


User Profile Reset: No



Additional Info:
see attached picture for an example of hidden text


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 Alan 2018-03-08 18:34:31 UTC
Created attachment 140481 [details]
Tooltips hinding text
Comment 2 Buovjaga 2018-03-11 14:20:08 UTC
You should be able to turn off tooltips entirely by going to expert config, search for:
org.openoffice.Office.Common/help
Double-click the Help - Tip entry so it turns false.

I don't think disabling individual tooltips would be accepted as a feature.
Comment 3 Alan 2018-03-15 15:21:09 UTC
Can you ask if it would be accepted? Maybe add to the time that a tooltip appears in a table? I know how to turn off all tooltips, I've been doing that since LO 4 or so.
Comment 4 Buovjaga 2018-03-19 16:52:26 UTC
Hmm, I looked into it some more and it seems to be annoying a lot of people.
There was this recent thread with Heiko asking to open a report: http://nabble.documentfoundation.org/Writer-how-to-disable-table-s-tool-tips-td4232432.html
So I am including design team.

If this is implemented, I guess it would be put in the expert config.

I also tried to find out, if adding a macro to table focus event is possible, but it seems it's not.
Comment 5 Heiko Tietze 2018-03-20 09:42:34 UTC
Wasn't easy for me to repro the tooltip; one has to place cursor and mouse pointer at the right positions (never run into the trouble with those tooltips therefore).

Besides the expert option, which is always on the table, I wonder if we can drop the tips as they are not very supportive.
Comment 6 csongor 2018-03-21 02:18:12 UTC
Created attachment 140763 [details]
semi-transparent tooltip
Comment 7 csongor 2018-03-21 02:18:47 UTC
Created attachment 140764 [details]
semi-transparent tooltip - GIMP
Comment 8 csongor 2018-03-21 02:19:06 UTC
(In reply to Heiko Tietze from comment #5)
> Wasn't easy for me to repro the tooltip; one has to place cursor and mouse
> pointer at the right positions (never run into the trouble with those
> tooltips therefore).

Actually, the tooltips appear whichever horizontal or vertical line of the table I hover over with the mouse. 

I had an idea that making the tooltip semi-transparent could solve the problem. I created a sample with gimp and it is not good. Depending on the transparency level, either the tooltip itself or the content behind it, one of them is hard to read. I'm just writing it so that you don't waste your time with it. :)

I attach a gimp file if you want to play with the transparency and a *.png to show how it looks with transparency=50%.
Comment 9 Heiko Tietze 2018-03-21 20:52:14 UTC
We discussed this topic in the design meeting and hesitate to remove the tooltips because of accessibility. As a compromise we recommend to introduce an expert option that solely disables tooltips in tables.
Comment 10 Samuel Mehrbrodt (CIB) 2018-03-23 12:08:41 UTC
(In reply to Heiko Tietze from comment #9)
> We discussed this topic in the design meeting and hesitate to remove the
> tooltips because of accessibility. As a compromise we recommend to introduce
> an expert option that solely disables tooltips in tables.

Are you sure that people who use a11y tools need these tooltips? Maybe you ask one of them. I am not sure they use that as they probably use the keyboard or the options dialog to resize the table. And even if they use the mouse, the cursor already gets changed into a resize cursor, so there already is a visual indication of the resize mode. And screen readers surely can read the cursor state too!?

Also we don't have this kind of tooltips on other objects (graphic objects e.g.) which you can resize.

I would prefer to remove the tooltips instead of adding another layer of complexity here.

Word also has no tooltips on the resize handles.
Comment 11 Buovjaga 2018-03-23 13:42:07 UTC
(In reply to Samuel Mehrbrodt (CIB) from comment #10)
> (In reply to Heiko Tietze from comment #9)
> > We discussed this topic in the design meeting and hesitate to remove the
> > tooltips because of accessibility. As a compromise we recommend to introduce
> > an expert option that solely disables tooltips in tables.
> 
> Are you sure that people who use a11y tools need these tooltips? Maybe you
> ask one of them. I am not sure they use that as they probably use the
> keyboard or the options dialog to resize the table. And even if they use the
> mouse, the cursor already gets changed into a resize cursor, so there
> already is a visual indication of the resize mode. And screen readers surely
> can read the cursor state too!?
> 
> Also we don't have this kind of tooltips on other objects (graphic objects
> e.g.) which you can resize.
> 
> I would prefer to remove the tooltips instead of adding another layer of
> complexity here.
> 
> Word also has no tooltips on the resize handles.

Stuart: I noticed you made the point "we should keep the tooltips because of accessibility" in the design meeting. Can you elaborate on this?
Comment 12 Heiko Tietze 2018-03-28 09:58:50 UTC
Patch here https://gerrit.libreoffice.org/#/c/51776/ blocked by Samuel with the idea to remove the tips. Stuart, you are the advocate of a11y.
Comment 13 V Stuart Foote 2018-03-28 15:30:58 UTC
Sorry Heiko, just had a closer look at this from a11y perspective I'd raised.

These QUICK tips [1] are only used in the sw edit window RequestHelp() [2], we don't provide them in calc or draw/impress tables. Also, the HelpEvent [3] for these seems to have a fixed 4 sec timer (but I could not find where it is set)--and that timer does not respond to setting of HelpTipSeconds or IsHelpTipsDisapear in Expert configuration [4].

Working with NVDA 2018.1 and a 6.0.3.1 these sw table QUICK tips are not even exposed as events to the Assistive Technology. 

So no a11y objection, and we either provide general expert configuration to set the Help event timer for the QUICK and BALLON help items--or we could simply remove these as Samuel suggests.

=-ref-=
[1] https://opengrok.libreoffice.org/xref/core/sw/inc/strings.hrc#1176
[2] https://opengrok.libreoffice.org/xref/core/sw/source/uibase/docvw/edtwin2.cxx#394
[3] https://opengrok.libreoffice.org/xref/core/include/vcl/event.hxx#179
[4] https://gerrit.libreoffice.org/#/c/17481/
Comment 14 Heiko Tietze 2018-03-29 10:03:39 UTC
(In reply to V Stuart Foote from comment #13)
> So no a11y objection, and we ... could
> simply remove these as Samuel suggests.

Changing the summary back from "Add expert configuration entry to disable tooltips in tables"
Comment 15 Commit Notification 2018-04-03 07:21:27 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=07ec28da82c8e965558e020651be13033653c648

tdf#116297 - Remove table tooltips

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Alan 2018-04-09 13:56:45 UTC
I just tested the 6.1 daily build and the tooltips are gone. You don't know how much this makes every day I work so much better. All the work that went into this really, really appreciated.
Thank you Heiko and everyone else who worked on this.
Comment 17 Heiko Tietze 2018-04-09 14:28:04 UTC
(In reply to Alan from comment #16)
> You don't know how much this makes every day I work so much better. 
> All the work that went into this really, really appreciated.

Happy to be of service :-)