Bug 116299 - Link to external data not properly finding and loading Coinmarket APIs
Summary: Link to external data not properly finding and loading Coinmarket APIs
Status: RESOLVED DUPLICATE of bug 114995
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.2.1 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL: https://coinmarketcap.com/api/
Whiteboard:
Keywords: bibisected, bisected, filter:ods, filter:xlsx
Depends on:
Blocks:
 
Reported: 2018-03-09 00:34 UTC by greg
Modified: 2018-03-12 14:51 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
pdf files of screen shots to the hang (455.27 KB, image/png)
2018-03-09 14:35 UTC, greg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description greg 2018-03-09 00:34:45 UTC
Description:
Loading external web based data source not properly loading public APIs. Window when looking for data stays blank not able to select the next step the data and parsing parameters.  https://api.coinmarketcap.com/v1/ticker/?limit=10 or https://api.coinmarketcap.com/v1/ticker/bitcoin/. Website instructions are here https://coinmarketcap.com/api/

Steps to Reproduce:
1. Open Spreadsheet in Libra Office
2. Click on Insert > Link to External Data
3. Insert URL of external data source
4. Enter/Return
5. text import window opens to select options, shows live sample data, 
6. Click OK button, then hangs

Actual Results:  
blank no results, must force quit to get control back

Expected Results:
hung window


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
also did not work with version 4.3.4.1 same results with most current version

Version says up to date when checked


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_3) AppleWebKit/604.5.6 (KHTML, like Gecko) Version/11.0.3 Safari/604.5.6
Comment 1 Alex Thurgood 2018-03-09 08:30:31 UTC
Tested on
Version: 6.1.0.0.alpha0+
Build ID: 9122f4598450d8a96e63fb29cc8166a6ae09587a
CPU threads: 4; OS: Mac OS X 10.13.3; UI render: default; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group

I don't see an entry under Insert that allows me to do step 2.

If I go to the Data menu, I see various possibilities there (Streams, Source, Data Provider), but which one are you actually talking about ?
Comment 2 greg 2018-03-09 14:35:06 UTC
Created attachment 140504 [details]
pdf files of screen shots to the hang

red typing on image is last step where it hangs no data import.
Comment 3 Xisco Faulí 2018-03-12 14:46:02 UTC
I can reproduce it in

Versió: 6.0.2.1
ID de la construcció: 1:6.0.2~rc1-0ubuntu0.16.04.1~lo1
Fils de CPU: 4; SO: Linux 4.13; Renderitzador de la IU: per defecte; VCL: gtk3; 
Configuració local: ca-ES (ca_ES.UTF-8); Calc: group

but not in

Version: 6.1.0.0.alpha0+
Build ID: adc6ba2ad502f095dde8f36242fda9aaa6c276fd
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Closing as RESOLVED WORKSFORME
Comment 4 Xisco Faulí 2018-03-12 14:51:58 UTC
Fixed in 40530d0ce4883ac999d53f86c0483e1a47c9fd74

*** This bug has been marked as a duplicate of bug 114995 ***