Bug 116304 - UI: No update of the zoomfactor percentage in the right corner when zooming with OpenGL enabled
Summary: UI: No update of the zoomfactor percentage in the right corner when zooming w...
Status: RESOLVED DUPLICATE of bug 116208
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-09 09:40 UTC by Telesto
Modified: 2018-03-11 18:30 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screencast (307.55 KB, video/mp4)
2018-03-09 14:35 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-03-09 09:40:09 UTC
Description:
UI: No update of the zoomfactor percentage in the right corner when zooming with OpenGL enable

Steps to Reproduce:
1. Launch Writer
2. Zoom in and out (ctrl+scroolwheel)
3. The percentage given in the right corner will stay the same (the zoom factor dialog is working correctly)


Actual Results:  
No update of the zoomfactor percentage. 

Expected Results:
A correctly displayed zoom factor


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 6.1.0.0.alpha0+
Build ID: d6b33e49a5e9c51827eda9c5ba16d8daeb27e8af
CPU threads: 4; OS: Windows 6.3; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-03-07_23:26:53
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Jacques Guilleron 2018-03-09 13:01:05 UTC
Hi Telesto,

I don't reproduce with
LO 6.1.0.0.alpha0+ Build ID: 3c913c3844acae8ee0d80ab174133bdc7677efea
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-02-14_00:19:27
Locale: en-US (fr_FR); Calc: CL
There is a small lag. 
Only Windows 6.1?
Comment 2 Telesto 2018-03-09 13:57:46 UTC
(In reply to Jacques Guilleron from comment #1)
Thanks for testing. Only to be certain: Did you test this with OpenGL enabled? It's an OpenGL only bug; Default rendering is working fine :-)
Comment 3 Dieter Praas 2018-03-09 14:29:36 UTC
My observation: The percentage given in the right corner will stay the same until you stop pressing ctrl => is this a bug?

tested with OpenGL enabled in

Version: 6.1.0.0.alpha0+ (x64)
Build ID: d64ce643275e0b2b0dea9e532fc261391dc8793c
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-03-01_03:24:30
Locale: de-DE (de_DE); Calc: CL
Comment 4 Telesto 2018-03-09 14:35:53 UTC
Created attachment 140505 [details]
Screencast
Comment 5 Telesto 2018-03-09 14:57:33 UTC
(In reply to Dieter Praas from comment #3)
> My observation: The percentage given in the right corner will stay the same
> until you stop pressing ctrl => is this a bug?

I'm not seeing any chance.. Even when I stop pressing ctrl (see screencast)

Version: 6.1.0.0.alpha0+
Build ID: fb29e6eeeaad5255bb924ff59162a83ed80bfb0a
CPU threads: 4; OS: Windows 6.3; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-03-09_03:14:44
Locale: nl-NL (nl_NL); Calc: CL
Comment 6 Jean-Baptiste Faure 2018-03-11 17:13:44 UTC
Same problem as bug 116208 ?

Best regards. JBF
Comment 7 Telesto 2018-03-11 18:30:56 UTC

*** This bug has been marked as a duplicate of bug 116208 ***