Bug Hunting Session
Bug 116318 - Wrong import of Arabic language when opening Arabic PDF by LO Draw
Summary: Wrong import of Arabic language when opening Arabic PDF by LO Draw
Status: RESOLVED DUPLICATE of bug 89471
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.0.2.1 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-09 15:31 UTC by yousifjkadom
Modified: 2018-03-20 12:32 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
test (22.33 KB, application/pdf)
2018-03-09 15:31 UTC, yousifjkadom
Details

Note You need to log in before you can comment on or make changes to this bug.
Description yousifjkadom 2018-03-09 15:31:22 UTC
Hi. 

LibreOffice Draw act as very good PDF editor for text-based PDF with Latin contents like English !

However, such great ability is COMPLETELY absent for Arabic Language ! When open Arabic PDF by PDF draw, the Arabic characters will appear separated by gaps & as if inverted by mirror ... 

Please open attached PDF in any PDF viewer like Okular or Adobe reader. Then open it in LibreOffice Draw & compare both to see what I mean.

Please notice that this PDF sample is created by LibreOffice itself.

Many thanks for your very hard efforts !
Comment 1 yousifjkadom 2018-03-09 15:31:54 UTC
Created attachment 140508 [details]
test
Comment 2 yousifjkadom 2018-03-09 15:34:16 UTC
I forgot to mention - though it was about 2 years since last time used Windows OS - in my last use for Windows this bug was existing on Windows 7 also.
Comment 3 Mark Hung 2018-03-11 09:14:29 UTC
Is this duplicate with tdf#89471 or tdf#97131?
Comment 4 Buovjaga 2018-03-11 15:51:37 UTC
(In reply to Mark Hung from comment #3)
> Is this duplicate with tdf#89471 or tdf#97131?

bug 89471 or bug 97131
NEEDINFO while waiting for evaluation from yousif
Comment 5 yousifjkadom 2018-03-19 21:26:32 UTC
Hi. Sorry for delay in response. Yes, it is a clon of bugs you mentioned above.

But please I think there is a progression in this sector: please look for this bug which is fixed:

https://bugs.documentfoundation.org/show_bug.cgi?id=60533

Is bug 60533 related to this issue ? It seem to me that it is related ....
Comment 6 Buovjaga 2018-03-20 12:32:51 UTC
Thanks, but I still reproduce the problem with latest build.

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: 3837901ef422d432f709dd95352796a54b58aae6
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on March 20th 2018

*** This bug has been marked as a duplicate of bug 89471 ***