Bug 116361 - Subscript causes additional vertical border to be added when setting borders through character formatting
Summary: Subscript causes additional vertical border to be added when setting borders ...
Status: RESOLVED DUPLICATE of bug 126353
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Borders
  Show dependency treegraph
 
Reported: 2018-03-12 10:26 UTC by Santi
Modified: 2019-08-05 11:25 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
odt file where you can find the bug (10.48 KB, application/vnd.oasis.opendocument.text)
2018-03-18 20:48 UTC, Santi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Santi 2018-03-12 10:26:02 UTC
Description:
As I'm using libreoffice Versión: 6.0.2.1 (x64)
compilation id: f7f06a8f319e4b62f9bc5095aa112a65d2f3ac89 in Spanish I'll write the words from menus in spanish.
When I use | formato | caracter | bordes in a expresion with subindex there appear a unexpected line.

Steps to Reproduce:
1. I have a text with subindex
2. I select format > character > border
3. I select rectangular border

It happens too if I change the order.

Actual Results:  
The frame is parted in two because of a unexpected line.

Expected Results:
A normal, rectangular frame.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 Buovjaga 2018-03-13 19:03:38 UTC
(In reply to Santi from comment #0)
> 1. I have a text with subindex

Please attach an example file at this point.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the document.
Comment 2 Santi 2018-03-18 20:48:32 UTC
Created attachment 140697 [details]
odt file where you can find the bug

This process is a little bit confused to me. Please, make it more simple.
Comment 3 Buovjaga 2018-03-19 14:25:50 UTC
Thanks, I could reproduce it. At least in my tests (on Linux & Windows), it does not help, if I do the subscript with keyboard shortcut.

Steps:
1. Input something like an = 5n - 2
2. Set the n in an to subscript by for example Ctrl-Shift-B
3. Select everything
4. Format - Character - Borders: set all 4 borders

Bisected to

https://cgit.freedesktop.org/libreoffice/core/commit/?id=d5fab973d0af95c433c5f6a9492014f7db642489

tdf#87224 Merge character borders across different scripts.
Character borders were broken when it contains multiple scripts.
Merge borders on kern portions and draw its border as necessary.
Refer to correct previous portion so it decide whether it join
previous or next border correctly.

(In reply to Santi from comment #2)
> This process is a little bit confused to me. Please, make it more simple.

How should we make it more simple?
Comment 4 Santi 2018-03-23 20:52:42 UTC
Thank you. Beautiful work!

>> This process is a little bit confused to me. Please, make it more simple.

> How should we make it more simple

With less fields, if possible.
Comment 5 Xisco Faulí 2018-06-05 19:37:02 UTC
Adding Cc: to Mark Hung
Comment 6 QA Administrators 2019-06-06 02:53:28 UTC Comment hidden (obsolete, spam)
Comment 7 Justin L 2019-08-05 11:25:48 UTC
I think the description of the newer report is better, so marking this one as the duplicate.

*** This bug has been marked as a duplicate of bug 126353 ***