Bug 116375 - FILEOPEN: no response to open WPS .DOC containing thumbnail.emf of 6MB (OK if resaved in MSO as doc or docx)
Summary: FILEOPEN: no response to open WPS .DOC containing thumbnail.emf of 6MB (OK if...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc, haveBacktrace, perf
Depends on:
Blocks: DOC-Opening
  Show dependency treegraph
 
Reported: 2018-03-13 10:08 UTC by lgw.3g
Modified: 2021-09-27 14:16 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
one doc with an image header mark (228.00 KB, application/wps-office.doc)
2018-03-13 10:09 UTC, lgw.3g
Details
bt with debug symbols (35.10 KB, text/plain)
2019-04-22 10:01 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lgw.3g 2018-03-13 10:08:11 UTC
Description:
Libreoffice writer has no response while  opening one ms-office document with an image header mark. 

Actual Results:  
can not open the ms-office document

Expected Results:
can open the doc 


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.108 Safari/537.36
Comment 1 lgw.3g 2018-03-13 10:09:32 UTC
Created attachment 140604 [details]
one doc with an image header mark
Comment 2 Xisco Faulí 2018-03-13 10:28:38 UTC
Reproduced in

Version: 6.1.0.0.alpha0+
Build ID: adc6ba2ad502f095dde8f36242fda9aaa6c276fd
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.10; Render: default; 

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 3 Roman Kuznetsov 2018-12-25 09:37:23 UTC
in attach is a .doc file

just for history: in

Version: 6.2.0.1
Build ID: 0412ee99e862f384c1106d0841a950c4cfaa9df1
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

it opens fine and LO works as should
Comment 4 Timur 2018-12-25 17:22:39 UTC Comment hidden (obsolete)
Comment 5 Julien Nabet 2019-04-22 10:01:33 UTC
Created attachment 150914 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I could reproduce this.

I also noticed this on console:
warn:filter.ms:7418:7418:filter/source/msfilter/msdffimp.cxx:6280: remaining record longer than available data, ppt or parser is wrong
Comment 6 Noel Grandin 2019-05-30 14:54:08 UTC
It is stuck inside writer layout - this is a layout looping problem
Comment 7 Timur 2021-03-29 06:23:40 UTC Comment hidden (obsolete)
Comment 8 Roman Kuznetsov 2021-09-25 15:14:01 UTC
LO opens the doc instantly in

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 1516711eb7861a08cc9fd19ec867360737a6d070
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Vulkan; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: threaded

may be it's only Linux problem?

Xisco, could you please retest it?
Comment 9 Timur 2021-09-27 13:38:07 UTC Comment hidden (me-too)
Comment 10 Timur 2021-09-27 13:49:38 UTC
In my case no response in both Win and Lin with LO 7.3+.
We know that multiple users reproduce and don't know why some don't.

(Roman, please write but test more before changing status. You also didn't repro before, and reproducing once is necessary to reach some conclusion).
Comment 11 Xisco Faulí 2021-09-27 14:16:50 UTC
Still reproducible in

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: b63c5ade3554a42def4bce94f9fd67ea66528214
CPU threads: 4; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded