Bug Hunting Session
Bug 116446 - Font selection widget with hierachy, filters, favorites
Summary: Font selection widget with hierachy, filters, favorites
Status: RESOLVED DUPLICATE of bug 91130
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.2.1 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-List
  Show dependency treegraph
 
Reported: 2018-03-17 11:05 UTC by Andreas
Modified: 2018-03-19 10:31 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas 2018-03-17 11:05:23 UTC
Description:
The font selection list must be improved IMO.
At the moment all fonts are shown in one big list. This is not adequate for the amount of fonts that are installed on modern computers (especially when you install additional fonts). Furthermore different entires of the same font family get a dedicated line on their own in this list.

Thus a hierarchical font selection has to be introduced. For an example what I mean, you can have a look at the gnome-specimen font viewer.
The top element in the hierachy could be the fonts that are used in the current document.

Additionally, different filters should be implemented (e.g. search for styles, bold, semi-bold, hand written, etc.). It would also be nice if the user can add tags/keywords to fonts such that they can be found more easily.

To avoid searching the same font over and over again, a favorites feature should be implemented.

---
Motivation for this feature can also be found when someone (like me) installs the google fonts repo from github, containing thousands of fonts. If the libreoffice team can make the font selection good enough to manage such a huge amount of fonts, beatiful documents could emerge ;)

Steps to Reproduce:
1. download the google font repo and extract it in your OS font directory
2. try to find a suited font for your work in the list of thousands of fonts
3. it definitely can be improved

Actual Results:  
overwhelming amount of fonts to select from and no means to search, except for name (whiche are more or less random for fonts)

Expected Results:
fonts structured in some hierarchy and means to search for fonts other than by name


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Comment 1 Heiko Tietze 2018-03-19 10:31:26 UTC
Thanks for reporting. The design team recently published a blog post [1] with ideas how to improve the situation more generally as there are numerous tickets around this topic. Closing as duplicate of 91130 but could also be 101478.

[1] https://design.blog.documentfoundation.org/2018/02/18/improvements-font-listing/

*** This bug has been marked as a duplicate of bug 91130 ***