Bug Hunting Session
Bug 116455 - Hidden dialog box when creating new database UI
Summary: Hidden dialog box when creating new database UI
Status: RESOLVED DUPLICATE of bug 114648
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.0.2.1 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-03-17 17:46 UTC by kam3don
Modified: 2018-03-19 17:25 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kam3don 2018-03-17 17:46:49 UTC
Description:
File > New > Database brings up a blank window. The dialog box for creating the new database opens behind this, and in order to find it I have to do a three-finger down swipe (App Expose) to make visible all LibreOffice windows and dialog boxes currently open. Can't even use the Window menu, because all menus except LibreOffice and File disappear when selecting File > New > Database.

I did a screencast showing what happens.

I turned off OpenGL and restarted LO to see if this made a difference. It didn't.

LibreOffice 6.0.2.1 Mac OS High Sierra 10.13.3

Steps to Reproduce:
1. File > New > Database
2.
3.

Actual Results:  
A blank window appears.

Expected Results:
The new database dialog box should appear.


Reproducible: Always


User Profile Reset: No



Additional Info:
Screencast: http://www.screencast.com/t/wR2ohWwDDD


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.186 Safari/537.36
Comment 1 Julien Nabet 2018-03-17 21:11:49 UTC
On pc Debian x86-64 with master sources updated yesterday, I could reproduce this.
Comment 2 Julien Nabet 2018-03-17 21:34:01 UTC
I could reproduce this only with gtk3 rendering, not with gtk, kde4 or gen renderings.

Caolán: thought you might be interested in this one. Indeed, even if it also concerns MacOs, on Linux, it concerns only gtk3 rendering (see my previous comment).
Comment 3 Telesto 2018-03-18 10:23:20 UTC
For the record. This is a dupe of Bug 114648
Comment 4 Julien Nabet 2018-03-18 10:25:31 UTC
(In reply to Telesto from comment #3)
> For the record. This is a dupe of Bug 114648

You're right but this also impacts Linux/gtk3.
Comment 5 Xisco Faulí 2018-03-19 17:07:56 UTC
I can't reproduce it in

Version: 6.1.0.0.alpha0+
Build ID: 2dd2d2fd9924e50c5b68c8942c26bf8a07fa2bf0
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 6 Xisco Faulí 2018-03-19 17:25:39 UTC
Regression introduced by 6f31670783b3445a8073bd49fe4c041b655e91b3
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 114648 ***