Bug 116490 - Incorrect characters in font DejaVu Sans when copying from PDF
Summary: Incorrect characters in font DejaVu Sans when copying from PDF
Status: RESOLVED DUPLICATE of bug 115117
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.0.2.1 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-19 10:46 UTC by Harry.dent
Modified: 2018-04-27 16:33 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
ODT that reproduces PDF export error (8.84 KB, application/vnd.oasis.opendocument.text)
2018-03-19 10:47 UTC, Harry.dent
Details
PDF file produced containing poor character mappings (21.70 KB, application/pdf)
2018-03-19 10:49 UTC, Harry.dent
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Harry.dent 2018-03-19 10:46:37 UTC
Description:
Exporting certain .odt files using the [File > Export As > Export as PDF...] or [File > Export As > Export Directly as PDF] options produces a PDF file that contains correct-looking characters. Incorrect characters are obtained when selecting and copying from the PDF.

Bug only occurs when the the font DejaVu Sans is used.

Steps to Reproduce:
1. Run `libreoffice6.0 --headless --convert-to pdf:writer_pdf_Export reproduced.odt`

OR

1. Open `reproduced.odt`
2. Choose [File > Export As > Export Directly as PDF]

Actual Results:  
Creates `reproduced.pdf`, which contains incorrectly mapped characters:

> sgfsglh sgeohsglshg seo seo soef of
> fnall

Expected Results:
Creates `reproduced.pdf`, which contains correctly mapped characters!

> sgfsglh sgeohsglshg seo seo soef ofi
> final


Reproducible: Always


User Profile Reset: No



Additional Info:
Upload of `reproduced.odt` to follow.


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/64.0.3282.167 Chrome/64.0.3282.167 Safari/537.36
Comment 1 Harry.dent 2018-03-19 10:47:53 UTC
Created attachment 140704 [details]
ODT that reproduces PDF export error
Comment 2 Harry.dent 2018-03-19 10:49:16 UTC
Created attachment 140705 [details]
PDF file produced containing poor character mappings
Comment 3 Timur 2018-03-19 12:32:58 UTC Comment hidden (obsolete)
Comment 4 Khaled Hosny 2018-03-19 13:21:48 UTC
Does this happen only when running headless?
Comment 5 Harry.dent 2018-03-19 13:32:43 UTC
(In reply to Khaled Hosny from comment #4)
> Does this happen only when running headless?

This happens when running headless and non-headless.
Comment 6 Harry.dent 2018-03-19 17:42:25 UTC
Further testing revealed that the issue is also present for following fonts: 

Lato Semibold
Lato
Lato Black
Lato Medium
TeX Gyre Chorus
Standard Symbols L
Lato Thin
OpenSymbol
TeX Gyre Adventor
Dingbats
DejaVu Sans
DejaVu Serif
TeX Gyre Schola
Carlito
DejaVu Serif Condensed
TeX Gyre Heros
TeX Gyre Termes
Lato Hairline
TeX Gyre Cursor
TeX Gyre Bonum
DejaVu Sans Light
Lato Heavy
DejaVu Sans Condensed
Lato Light
TeX Gyre Pagella
TeX Gyre Heros Cn
Comment 7 Harry.dent 2018-03-19 17:44:28 UTC
Oops looks like I included Dingbats, OpenSymbol, etc. in that list. Please ignore them!
Comment 8 Khaled Hosny 2018-03-20 01:37:07 UTC

*** This bug has been marked as a duplicate of bug 66597 ***
Comment 9 Khaled Hosny 2018-03-20 01:39:19 UTC
Bug 66597 is becoming a kind of meta bug and different issues that can’t all be fixed at the same time. Lets fix this one here.
Comment 10 Khaled Hosny 2018-03-20 02:26:38 UTC

*** This bug has been marked as a duplicate of bug 115117 ***