Bug Hunting Session
Bug 116496 - A new page style will have 'header on' without being checked at all
Summary: A new page style will have 'header on' without being checked at all
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Mike Kaganski
URL:
Whiteboard: target:6.3.0 target:6.2.0.1 target:6.1.5
Keywords: bibisected, bisected, needUITest, regression
: 118278 123133 (view as bug list)
Depends on:
Blocks: Writer-Styles-Page
  Show dependency treegraph
 
Reported: 2018-03-19 14:44 UTC by Telesto
Modified: 2019-02-03 13:40 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-03-19 14:44:02 UTC
Description:
A new page style will have 'header on' without being checked at all

Steps to Reproduce:
1. Launch Writer
2. Enabled formatting marks (CTRL+F10) -> Makes it more obvious
3. Styles Deck -> Page Styles 
4. Right click inside the styles list -> New
5. Check the 'header' tab -> Header on unchecked (as expected)
6. Press OK -> Notice that a header is created!
7. Check the inserted style (untitled 1) -> Notice that Header on being enabled 

Actual Results:  
Header is enabled, without being checked

Expected Results:
Shouldn't happen


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.1.0.0.alpha0+
Build ID: e5bc7fa4e83b33fc3eee343e560a4f8cb91eacd6
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-03-14_23:37:38
Locale: nl-NL (nl_NL); Calc: group


User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Dieter Praas 2018-03-19 18:09:11 UTC
Reprodcible for me with

Version: 6.1.0.0.alpha0+ (x64)
Build ID: d64ce643275e0b2b0dea9e532fc261391dc8793c
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-03-01_03:24:30
Locale: de-DE (de_DE); Calc: CL

but not in

Version: 5.4.6.2 (x64)
Build-ID: 4014ce260a04f1026ba855d3b8d91541c224eab8
CPU-Threads: 4; BS: Windows 6.19; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group
Comment 2 Xisco Faulí 2018-03-19 18:24:14 UTC
Regression introduced by:

author	Szymon Kłos <szymon.klos@collabora.com>	2017-09-21 11:31:53 +0200
committer	Szymon Kłos <szymon.klos@collabora.com>	2017-09-23 16:37:06 +0200
commit	22e94ab1860b1bdea8d107d4e8824f63c6b1c8c5 (patch)
tree	6e15c6e7a0fae50664f73edecf2999b47908179a
parent	f53b6890525abcf3ea2c1955c8ff26af53c3a8b3 (diff)
Watermark: apply when new page style is created

Bisected with: bibisect-linux64-6.0

Adding Cc: to Szymon Kłos
Comment 3 Xisco Faulí 2018-06-21 15:57:39 UTC
*** Bug 118278 has been marked as a duplicate of this bug. ***
Comment 4 Pierre C 2018-06-21 16:08:36 UTC
You can check all the page style, all the headers are activated, witch is a little bit more annoying..
Comment 5 Pierre C 2018-10-18 07:31:53 UTC
This is still present with LO 6.1.3. And really it's now very boring to use page still, as you try to not use it knowing that you will have to change all yours pages's styles.
Here ilt's an nice feature that now I try not to use it... (like more and more nice features...)
Comment 6 Thomas Lendo 2018-10-24 10:39:17 UTC
Still reproducible in version: 6.2.0.0.alpha1+ (x64)
Build ID: ae9f37ba753519ae4a2ae6384d052d417359602f
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-10-23_02:03:22
Locale: de-AT (de_AT); Calc: CL
Comment 7 Mike Kaganski 2018-12-18 06:20:38 UTC
https://gerrit.libreoffice.org/65303
Comment 8 Commit Notification 2018-12-18 08:44:44 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/c4f3bd7c94cacb52f7a791a0d364818cee6080b6%5E%21

tdf#116496: don't add header when setting empty watermark

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Xisco Faulí 2018-12-19 10:06:41 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: 78073ecfdc50e78e3ce094c1259779b7c3b88bc4
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Mike Kaganski, thanks for fixing this!!

cherry-picked to
6-2 https://gerrit.libreoffice.org/#/c/65415/
6-1 https://gerrit.libreoffice.org/#/c/65416/
Comment 10 Commit Notification 2018-12-19 20:26:54 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/b1059dcad84dccc68b45819ed0d74dcb577fe19e%5E%21

tdf#116496: don't add header when setting empty watermark

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2018-12-21 09:00:41 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/027e592758421287463b1a3bf64cb32d3ef96601%5E%21

tdf#116496: don't add header when setting empty watermark

It will be available in 6.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Oliver Brinzing 2019-02-03 13:40:08 UTC
*** Bug 123133 has been marked as a duplicate of this bug. ***