Bug 116504 - PDF export: The empty area in a PDF image is transparent when exporting the PDF, showing table borders hidden below it
Summary: PDF export: The empty area in a PDF image is transparent when exporting the P...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: PDF-Insert
  Show dependency treegraph
 
Reported: 2018-03-19 19:22 UTC by Telesto
Modified: 2021-02-13 07:28 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (16.74 KB, application/vnd.oasis.opendocument.text)
2018-03-25 16:52 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-03-19 19:22:56 UTC
Description:
The empty area in a PDF image is transparent when exporting the PDF, showing table borders hidden below it

Steps to Reproduce:
1. Open the attached file
2. Export to PDF (default settings)
3. Notice the visibility of the table border which is hidden in the ODT

Actual Results:  
Borders hidden below the image PDF image are visible 

Expected Results:
Shouldn't be


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
Version: 6.1.0.0.alpha0+
Build ID: e5bc7fa4e83b33fc3eee343e560a4f8cb91eacd6
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-03-14_23:37:38
Locale: nl-NL (nl_NL); Calc: CL

but not in
Versie: 4.4.7.2 
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL


User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Buovjaga 2018-03-25 16:47:48 UTC
You forgot to attach the file
Comment 2 Telesto 2018-03-25 16:52:37 UTC
Created attachment 140875 [details]
Example file

It's getting a habit :‑(
Comment 3 Buovjaga 2018-03-25 17:28:35 UTC
Repro.

Can we call it a regression, though, because PDF as image is a new feature (since 5.3)?

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: 54c2637c1c9b526ffd9423e2d8e431474b535276
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on March 25th 2018
Comment 4 QA Administrators 2019-03-27 03:41:53 UTC Comment hidden (obsolete)
Comment 5 Babak Razmjoo 2019-03-27 15:53:59 UTC
It is still present in:
Version: 6.2.2.2
Build ID: 2b840030fec2aae0fd2658d8d4f9548af4e3518d
CPU threads: 1; OS: Linux 5.0; UI render: default; VCL: x11 (or gtk3); 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 6 Aron Budea 2021-02-13 07:28:21 UTC
Not seeing the lines in the background in the exported PDF when exporting in LO 7.2.0.0.alpha0+ (066799b4a162aa0a4bc6aa28339f1f943a13971e).