Download it now!
Bug 116526 - UI: Badly timed dialog when Track Changes on and Show Changes off in Writer
Summary: UI: Badly timed dialog when Track Changes on and Show Changes off in Writer
Status: RESOLVED DUPLICATE of bug 113479
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.2.1 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-20 20:38 UTC by Darrell
Modified: 2018-03-21 17:43 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Darrell 2018-03-20 20:38:55 UTC
Description:
When I am editing a document in Writer with Track Changes turned on and Show Changes off, at a seemingly random time after I start making changes I see a dialog box titled "Show changes?" with the heading "Do you want to show changes to avoid delays?". The available options are Yes and No, and Writer appears to only need to be told once per document and session. The problem is that it does not consistently appear at the first change; in my experience it often pops up while I am typing a change, at which point it eats everything I type until I notice it or hit the space bar. The default response appears to be Yes, because if I type a space before I notice the pop-up dialog the pop-up is removed and Show Changes is turned on. This is a minor inconvenience, because it is very easy to turn Show Changes off again and I rarely have to retype more than a half dozen characters. It is, however, annoying that I have to answer No every time I embark on a long editing session, and it breaks my concentration, because I have to reread the text I was changing to see what needs to be re-entered.

Either the dialog should have an additional option, essentially "No and don't ask me again", or there should be an option to turn the dialog off; the latter would probably be the better choice.

Alternatively, determine why showing changes improves performance and fix it, or determine that it has already been fixed and remove the dialog entirely. I have been unable to detect a difference in performance between Show Changes on and off, but I am looking at relatively short documents (less than 150 pages).

Steps to Reproduce:
1. Open a document; I don't know if there is a lower bound on the size of the document.
2. Turn Track Changes on and Show Changes off.
3. Start making changes. Unfortunately, it may be necessary to make several dozen changes before the dialog is triggered; I have been unable to determine an upper bound.

Actual Results:  
Eventually the annoying dialog box pops up.

Expected Results:
I should be able to make it stop appearing.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 6.0.2.1
Build ID: 1:6.0.2~rc1-0ubuntu0.17.10.1~lo1
CPU threads: 6; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 Gabor Kelemen 2018-03-21 17:43:32 UTC

*** This bug has been marked as a duplicate of bug 113479 ***