Bug 116532 - Zotero plugin does not create its own Tab/Section in the Notebookbar
Summary: Zotero plugin does not create its own Tab/Section in the Notebookbar
Status: RESOLVED DUPLICATE of bug 101704
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0.1.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Notebookbar
  Show dependency treegraph
 
Reported: 2018-03-21 10:36 UTC by Pedro
Modified: 2018-03-26 07:37 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Zotero creates its own tab in the Ribbon UI but creates an ugly toolbar in the Notebookbar (207.69 KB, application/pdf)
2018-03-21 10:36 UTC, Pedro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro 2018-03-21 10:36:12 UTC
Created attachment 140771 [details]
Zotero creates its own tab in the Ribbon UI but creates an ugly toolbar in the Notebookbar

The open-source reference manager software Zotero creates a toolbar underneath the Notebookbar both in the Tabbed and Groupedbar Full options (didn’t test in the others. In Microsoft Word it generates its own tab. Is this something that can be fixed by the amazing LO devs or is it an issue that should be addressed to the Zotero devs?

For people that never wrote extensive research papers, tools like Zotero or Mendeley are crucial, they usually integrate quite cleanly in Libre Office. It would be nice if it integrated cleanly in the Notebookbar UIs.
Comment 1 Buovjaga 2018-03-24 19:43:11 UTC
(In reply to Pedro from comment #0)
> Created attachment 140771 [details]
> Zotero creates its own tab in the Ribbon UI but creates an ugly toolbar in
> the Notebookbar
> 
> The open-source reference manager software Zotero creates a toolbar
> underneath the Notebookbar both in the Tabbed and Groupedbar Full options
> (didn’t test in the others. In Microsoft Word it generates its own tab. Is
> this something that can be fixed by the amazing LO devs or is it an issue
> that should be addressed to the Zotero devs?
> 
> For people that never wrote extensive research papers, tools like Zotero or
> Mendeley are crucial, they usually integrate quite cleanly in Libre Office.
> It would be nice if it integrated cleanly in the Notebookbar UIs.

You should ask Zotero devs first. Remember that Notebookbar is still experimental!
Comment 2 Pedro 2018-03-25 11:22:20 UTC
I already submitted a bug report in their forums (they don't use a bug tracker).
Comment 3 Buovjaga 2018-03-25 16:49:28 UTC
(In reply to Pedro from comment #2)
> I already submitted a bug report in their forums (they don't use a bug
> tracker).

Please let us know the URL to the forum post.
Comment 4 Pedro 2018-03-25 23:21:34 UTC
Sure!

Here's the link:

https://forums.zotero.org/discussion/comment/304459#Comment_304459

Maybe one of you guys can sign up there and interact with the Zotero devs (it's an amazing open-source extension).
Comment 5 Buovjaga 2018-03-26 07:37:13 UTC
Ok, bwiernik's comment was enlightening. This report is indeed a duplicate of an existing one.

Please keep an eye on the meta bug and the issues it collects: https://bugs.documentfoundation.org/showdependencytree.cgi?id=102062&hide_resolved=1

It would be cool to have someone CC'd to all the Notebookbar metas in order to triage incoming issues & enhancement requests.

*** This bug has been marked as a duplicate of bug 101704 ***