Bug 116536 - FILEOPEN: Bullets are higher than the text
Summary: FILEOPEN: Bullets are higher than the text
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Szymon Kłos
URL:
Whiteboard: target:6.1.0 target:6.0.4 target:5.4.7
Keywords: bibisected, bisected, regression
: 115916 (view as bug list)
Depends on:
Blocks: Impress-Bullet-Number
  Show dependency treegraph
 
Reported: 2018-03-21 11:36 UTC by Xisco Faulí
Modified: 2018-04-12 00:09 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
comparison MSO 2010 and LibreOffice 6.1 (10.23 KB, image/png)
2018-03-21 11:36 UTC, Xisco Faulí
Details
LibreOffice 6.1 VS LibreOffice 5.3 VS MSO 2010 (133.42 KB, image/png)
2018-04-03 14:45 UTC, Xisco Faulí
Details
File created using "Steps to reproduce" in bug 115916 (11.66 KB, application/vnd.oasis.opendocument.presentation)
2018-04-04 20:38 UTC, Andrew Watson
Details
Screen shot of attachment 141097 loaded into LO 4.4.7.2 (85.74 KB, image/png)
2018-04-04 20:41 UTC, Andrew Watson
Details
Screen shot of attachment 141097 loaded into LO 6.0.4.0.0+ (73.57 KB, image/png)
2018-04-04 20:45 UTC, Andrew Watson
Details
Screenshot of attachment 141097 loaded into LO 6.1.0.0.alpha0+ (41.06 KB, image/png)
2018-04-04 20:49 UTC, Andrew Watson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-03-21 11:36:41 UTC
Created attachment 140783 [details]
comparison MSO 2010 and LibreOffice 6.1

Steps to reproduce:
1. Open attachment 76347 [details] from bug 62185

Observed behaviour: The bullet after the text is higher than it should be.

Reproduced in

Version: 6.1.0.0.alpha0+
Build ID: 234d0368c823eb1a74e973e051ac522e6b86e833
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2018-03-21 11:37:18 UTC
attachment 106316 [details] from bug 83889 is also affected
Comment 2 Xisco Faulí 2018-03-21 11:38:41 UTC
Regression introduced by:

author	Szymon Kłos <szymon.klos@collabora.com>	2018-03-09 20:26:35 +0100
committer	Szymon Kłos <szymon.klos@collabora.com>	2018-03-09 21:21:32 +0100
commit	63311c2d512f69bff9a2e3c012a4f36a91f23e19 (patch)
tree	1944d25aa0e11eca75037642ea901ddaa0ac1bd8
parent	70a768e2b66cdb0f7a68a47cd9a6be16f317eeeb (diff)
tdf#116101 Correct bullet position for linespacing > 100%

Bisected with: bibisect-linux64-6.1

Adding Cc: to Szymon Kłos
Comment 3 Szymon Kłos 2018-03-23 18:57:50 UTC
*** Bug 115916 has been marked as a duplicate of this bug. ***
Comment 4 Commit Notification 2018-03-29 15:00:31 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=596fd41b9b19e28bab0c84e3821f79cb5d468f24

tdf#116536 Fix bullet position with linespacing > 100

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Xisco Faulí 2018-04-03 14:45:42 UTC
Created attachment 141057 [details]
LibreOffice 6.1 VS LibreOffice 5.3 VS MSO 2010

After the commit, it looks better, however, it's slightly higher than in MSO 2010 or previous versions of LibreOffice
Anyway, I'm not going to reopen it.
@Szymon Kłos, I let you take that decision...
Comment 6 Andrew Watson 2018-04-04 20:38:50 UTC
Created attachment 141097 [details]
File created using "Steps to reproduce" in bug 115916

Created attached .odp file using "Steps to reproduce" in bug 115916 (subsequently marked as duplicate of bug 116536).

Loading this file into LO 4.4.7.2 shows pre-regeression behaviour - see screen shot on later comment.

Under:

Version: 6.0.4.0.0+
Build ID: 2a2aeaeef39f6a940838e2da69c5e1bc61e3793d
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-6-0, Time: 2018-04-03_16:01:52
Locale: en-GB (en_GB.UTF-8); Calc: group

 ... regression behaviour is still present (see second secreenshot).

Under: 

Version: 6.1.0.0.alpha0+
Build ID: 28012351ae273d41af548a29a14d9d842e66f6f6
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-04-03_23:16:06
Locale: en-GB (en_GB.UTF-8); Calc: group

 ... behaviour is back to pre-regression (see third screenshot). As under 4.4.7.2, the "-" character forming the bullet is still infintesimally higher than those forming the text (see red construction lines), but it's impossible to see this effect at less than about 2,000% magnification.

IMO it's reasonable to leave the bug as RESOLVED FIXED.
Comment 7 Andrew Watson 2018-04-04 20:41:53 UTC
Created attachment 141098 [details]
Screen shot of attachment 141097 [details] loaded into LO 4.4.7.2

Screen-shot showing pre-regression behaviour under LO 4.4.7.2.
Comment 8 Andrew Watson 2018-04-04 20:45:25 UTC
Created attachment 141099 [details]
Screen shot of attachment 141097 [details] loaded into LO 6.0.4.0.0+

Screenshot of attachment 141097 [details] loaded into:

Version: 6.0.4.0.0+
Build ID: 2a2aeaeef39f6a940838e2da69c5e1bc61e3793d
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-6-0, Time: 2018-04-03_16:01:52
Locale: en-GB (en_GB.UTF-8); Calc: group

Shows regression - bullet character is highly superscripted compared to text.
Comment 9 Andrew Watson 2018-04-04 20:49:43 UTC
Created attachment 141100 [details]
Screenshot of attachment 141097 [details] loaded into LO 6.1.0.0.alpha0+

Screenshot of attachment 141097 [details] loaded into:

Version: 6.1.0.0.alpha0+
Build ID: 28012351ae273d41af548a29a14d9d842e66f6f6
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-04-03_23:16:06
Locale: en-GB (en_GB.UTF-8); Calc: group

Bullet character is back to pre-regression position, superscripted by an almost-undetectable amount (see red construction lines).
Comment 10 Commit Notification 2018-04-10 15:21:40 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e3bcaf133db6c78b0a7baeada6f7692a12e07cb2&h=libreoffice-6-0

tdf#116536 Fix bullet position with linespacing > 100

It will be available in 6.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Andrew Watson 2018-04-11 21:07:09 UTC
Loaded attachment 141097 [details] into:

Version: 6.0.4.0.0+
Build ID: 0d78d17249a58d95b4aa2e8fe09f08e22f20c407
CPU threads: 4; OS: Mac OS X 10.11.6; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:libreoffice-6-0, Time: 2018-04-11_09:33:49
Locale: en-US (en.UTF-8); Calc: group

Works as it should -> IMO regression fixed in this version.

Also tested Build ID: 0d78d17249a58d95b4aa2e8fe09f08e22f20c407 against real-world .odp files that previously showed the regression behaviour under early LO 6 versions.  Again, they work as they should -> IMO regression fixed in this version.

Thanks!
Comment 12 Commit Notification 2018-04-11 21:49:59 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4661cd9d17e3f2dc619cb888efde54eb6cf5219a&h=libreoffice-5-4

tdf#116536 Fix bullet position with linespacing > 100

It will be available in 5.4.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.