Bug 116543 - Crash (fatal error) when attempting a mail merge print ( only the first time the connection is done)
Summary: Crash (fatal error) when attempting a mail merge print ( only the first time ...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: highest critical
Assignee: Mike Kaganski
URL:
Whiteboard: target:6.2.0 target:6.0.6 target:6.1.0.2
Keywords: bibisected, bisected, haveBacktrace, regression
: 116802 (view as bug list)
Depends on:
Blocks: Mail-Merge
  Show dependency treegraph
 
Reported: 2018-03-21 16:14 UTC by Telesto
Modified: 2018-09-03 10:26 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
gdb backtrace (19.04 KB, text/plain)
2018-04-04 17:38 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-03-21 16:14:36 UTC
Description:
Crash when attempting a mail merge print..

Steps to Reproduce:
1. Download attachment 116527 [details] (bug 116537) and unzip
2. Open the test.odt
3. Double click on '<Vorname>' field
4. Click browse -> Add database file "Test.ods
5. Expand and select 'Vorname"
6. Press OK
7. Press Print
8. Do you want to print a form letter -> YES
9. Press OK -> Crash

It happens every time; However, LibO 6.1. stops crashing after using the same file with an older version (in my case 4.4.7.2) in between or prior to Libo6.1. It starts crashing again after renaming of the ODS. For example to Test1.ods 

Actual Results:  
Crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Repro with
Version: 6.1.0.0.alpha0+
Build ID: dd4f1b1bd31daf080dc0420524712dc244e539b5
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-03-20_23:26:38
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Telesto 2018-03-21 16:20:19 UTC
not with
Version: 5.4.0.0.alpha1+
Build ID: 9feb7f7039a3b59974cbf266922177e961a52dd1
CPU threads: 4; OS: Windows 6.29; UI render: default; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 2 Xisco Faulí 2018-03-22 13:26:11 UTC
it seems the link to the attachment is incorrect.

The correct attachment is this one ---> attachment 140760 [details] from bug 116537

Reproduced in

Version: 6.1.0.0.alpha0+
Build ID: 751191ed2d7d6af6eddc3d738e8c45b0a2ab2572
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-03-21_23:24:05
Locale: es-ES (es_ES); Calc: group

but not in

Version: 6.1.0.0.alpha0+
Build ID: 234d0368c823eb1a74e973e051ac522e6b86e833
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 3 Xisco Faulí 2018-03-22 13:27:44 UTC
Also reproduced in

Versión: 6.0.1.1
Id. de compilación: 60bfb1526849283ce2491346ed2aa51c465abfe6
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group
Comment 4 Xisco Faulí 2018-03-22 13:33:58 UTC
@Jan-Marek, knowing it's only reproducible on win, I'm wondering if it's related to the scheduler refactoring...
Comment 5 Xisco Faulí 2018-03-28 09:00:01 UTC
Regression introduced by:

author	Szymon Kłos <szymon.klos@collabora.com>	2017-09-08 10:57:55 +0200
committer	Szymon Kłos <szymon.klos@collabora.com>	2017-09-09 11:42:50 +0200
commit	97477ee5e11951a5a25a91b89f1b71a1b78ac8f5 (patch)
tree	77d49f492b37bc05ac9eafc77b7a7f28c31530ed
parent	a45800f010f3e063c6f31426fcdba76aa5b43d3e (diff)
tdf#108572 remove connections only for current shell

Bisected with: bibisect-win32-6.0

Adding Cc: to Szymon Kłos

it seems the problem is only reproduced the first time we do the connection between the .odt file and the .ods file. After the first crash, it no longer crashes. Thus, the user folder needs to be removed every time
Comment 6 Xisco Faulí 2018-04-04 17:33:44 UTC
*** Bug 116802 has been marked as a duplicate of this bug. ***
Comment 7 Xisco Faulí 2018-04-04 17:34:38 UTC
Also reproduced on Linux using these steps https://bugs.documentfoundation.org/show_bug.cgi?id=116802#c0. As said, it's important to remove the user folder before...
Comment 8 Xisco Faulí 2018-04-04 17:38:39 UTC
Created attachment 141090 [details]
gdb backtrace
Comment 9 Xisco Faulí 2018-05-07 16:00:45 UTC
*** Bug 117480 has been marked as a duplicate of this bug. ***
Comment 10 Andrew Watson 2018-05-29 20:37:02 UTC
Reproduced in:

Version: 6.1.0.0.beta1
Build ID: 8c76dfe1284e211954c30f219b3a38dcdd82f8a0
CPU threads: 4; OS: Mac OS X 10.11.6; UI render: default; 
Locale: en-US (en.UTF-8); Calc: group

 .... using the steps to reproduce described in https://bugs.documentfoundation.org/show_bug.cgi?id=117480
Comment 11 tommy 2018-06-05 05:33:23 UTC
reproduced in 6.0.4

on my case, if I hit print button (print to file), LibreOffice Writer forced to close. The file empty 

$ file a0.odt 
a0.odt: empty

$ ls -lah a0.odt 
-rw------- 1 tommy tommy 0 Jun  5 12:29 a0.odt




Additional info : 

Fedora 28

$ uname -a
Linux kaciwer 4.16.9-300.fc28.x86_64 #1 SMP Thu May 17 06:39:18 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Version: 6.0.4.2
Build ID: 6.0.4.2-2.fc28
CPU threads: 4; OS: Linux 4.16; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.utf8); Calc: group
Comment 12 Mike Kaganski 2018-07-03 16:50:18 UTC
https://gerrit.libreoffice.org/56891

Also a failing assert when doing steps from comment 0, which is unrelated to the crash:
https://gerrit.libreoffice.org/56863
Comment 13 Commit Notification 2018-07-05 00:24:24 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=54d76f5203aa5f3ef0e5afdca9d131dadeb3794e

tdf#116543: don't forget to commit registrations in DB field editor

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Xisco Faulí 2018-07-05 11:40:32 UTC
Verified in

Version: 6.2.0.0.alpha0+
Build ID: 0e83efbccc180c957f77291fc0fdc6dd74eae0f4
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

@Mike, thanks for fixing this!!
Comment 15 Andrew Watson 2018-07-10 08:08:56 UTC
Bug confirmed still present in:

Version: 6.1.0.1.0+
Build ID: 9837faeaab59e030e500ed21da92dd6bed2806fe
CPU threads: 4; OS: Mac OS X 10.11.6; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:libreoffice-6-1, Time: 2018-07-10_00:21:46
Locale: en-US (en.UTF-8); Calc: group threaded

 .... using the steps to reproduce described in https://bugs.documentfoundation.org/show_bug.cgi?id=117480

Is there any chance that the LO 6.2 fix can also be brought forward to LO 6.1, please? Thanks.
Comment 16 Xisco Faulí 2018-07-10 08:34:00 UTC
Patches in gerrit are awaiting for review:
6-1: https://gerrit.libreoffice.org/#/c/57005/1
6-0: https://gerrit.libreoffice.org/#/c/57008/1
Comment 17 Commit Notification 2018-07-10 18:29:36 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3ca2651cae0477a0bfc72e2c2a17ba0433881092&h=libreoffice-6-0

tdf#116543: don't forget to commit registrations in DB field editor

It will be available in 6.0.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2018-07-11 08:59:35 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=39ba5e3bde93358af1b363da8f850bdc96806cfa&h=libreoffice-6-1

tdf#116543: don't forget to commit registrations in DB field editor

It will be available in 6.1.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Xisco Faulí 2018-07-13 09:10:10 UTC
*** Bug 118728 has been marked as a duplicate of this bug. ***
Comment 20 Andrew Watson 2018-08-24 08:44:23 UTC
"Steps to reproduce" for Bug 116543 does not trigger a crash in:

Version: 6.1.0.3
Build ID: efb621ed25068d70781dc026f7e9c5187a4decd1
CPU threads: 4; OS: Mac OS X 10.11.6; UI render: default; 
Locale: en-GB (en.UTF-8); Calc: group threaded

So it look as though this bug is indeed fixed.

However, "Steps to reproduce" for Bug 117480 (which is currently marked as a duplicate of Bug 116543) still triggers a crash in both:

Version: 6.1.0.3
Build ID: efb621ed25068d70781dc026f7e9c5187a4decd1
CPU threads: 4; OS: Mac OS X 10.11.6; UI render: default; 
Locale: en-GB (en.UTF-8); Calc: group threaded

Version: 6.1.0.3
Build ID: efb621ed25068d70781dc026f7e9c5187a4decd1
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-GB (en_GB.UTF-8); Calc: group threaded

There's a crash report for the Linux version here:

crashreport.libreoffice.org/stats/crash_details/d64871ad-755a-4342-a105-4f215be61e1f

So it seems that Bug 117480 is a separate (still unfixed) bug, and not in fact a duplicate of Bug 116543.