Download it now!
Bug 116545 - Exporting to PDF in Impress stretch one image for every slides/pages (OpenGL)
Summary: Exporting to PDF in Impress stretch one image for every slides/pages (OpenGL)
Status: RESOLVED DUPLICATE of bug 121615
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
5.4.5.1 release
Hardware: Other other
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-21 16:51 UTC by Roope
Modified: 2019-03-28 14:07 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Attached files, the original .odp and exported PDF (22.37 MB, application/x-zip-compressed)
2018-03-26 15:39 UTC, Roope
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roope 2018-03-21 16:51:29 UTC
Description:
HW+OS: this problem occurred with HP Omen x86, i5, 64 bit, windows 10, Impress rev. 5.4.5.1 and 6.0.2
It's not a problem with older PC: x86, AMD 64 bit, win 7, Impress rev. 5.2.5.1

Exporting to PDF stretch or zoom one image in every page in the slide set. It strange that there are only one stretched image in page/slide. No more than one per page. 
Size of image is as original, but inside of the "image border" the image is stretched totally out of "borders". It is possible to see only 10-30% from original image inside of the "image borders".



Steps to Reproduce:
1. create normal Impress pages with several images (jpg) to every pages
2. save the file (file size 20-25 Mb)
3. export to PDF (changing any settings will not help)
4. open the PDF-file in Foxit Reader or any other PDF reader
5. one image of the any pages are stretched in PDF, not in original .odp-file

Actual Results:  
One image of the any pages are stretched in PDF, not in original .odp-file

Expected Results:
PDF files should be look same as original files.  


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Tested with original file - no problems with older PC and older LibreOffice (5.2.5.1). Problems occurred only with new PC and new LibreOffice (5.4.5.1 and 6.0.2)  


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.186 Safari/537.36 OPR/51.0.2830.55
Comment 1 Roope 2018-03-21 18:07:39 UTC
I checked the original file again and noticed that some of images are .png files. Most of images are .jpg files. Stretched images are both of them.
Comment 2 Xavier Van Wijmeersch 2018-03-21 19:05:20 UTC
Thanks for reporting the problem.
Can you test it with a disabled opengl function or with safe mode.
Comment 3 Buovjaga 2018-03-24 18:37:27 UTC
Please attach a minimal example document, where this occurs.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the document.
Comment 4 Telesto 2018-03-25 09:25:14 UTC
Maybe connected to bug 113143 (Wild guess)
Comment 5 Roope 2018-03-26 15:39:21 UTC
Created attachment 140885 [details]
Attached files, the original .odp and exported PDF

Needed files - the original .odp and exported PDF files attached.
Comment 6 Roope 2018-03-26 15:46:56 UTC
This bug not look same as bug 113143 .
The image position is not moved from original, the one image is only stretched, one/page.
Comment 7 Buovjaga 2018-03-26 17:28:17 UTC
(In reply to Xavier Van Wijmeersch from comment #2)
> Thanks for reporting the problem.
> Can you test it with a disabled opengl function or with safe mode.

Roope: did you try with OpenGL disabled? Tools - Options - LibreOffice - View - Use OpenGL for all rendering

I get a perfect PDF export with your file.

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: add7a962bc33b3c1f2252a9920bebf324df688de
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on March 26th 2018
Comment 8 Telesto 2018-03-26 18:51:47 UTC
It's OpenGL related. Working fine without it.
Repro with
Version: 6.1.0.0.alpha0+
Build ID: 679a3b9314d56cad05b5ff2a2c2fa3d320f719bb
CPU threads: 4; OS: Windows 6.3; UI render: GL; 
Locale: nl-NL (nl_NL); Calc: CL

also repro with
Version: 5.1.0.0.alpha1+
Build ID: 49c2b9808df8a6b197dec666dfc0cda6321a4306
Threads 4; Ver: Windows 6.29; Render: GL;
Comment 9 Roope 2018-03-26 22:29:33 UTC
Buovjaga: Thanks! I tried without OpenGL and exporting works fine. Exporting tooks much more time but it works.

So, what should I do in future? Is this a problem in Impress or OpenGL? How to get correct OpenGL drivers (or plug-in?)? I suppose the OpenGL can generate problems with other apps, as well - if these problems are coming from there? Or is it still a problem only in Impress? How to verify?
Comment 10 Buovjaga 2018-03-27 06:57:43 UTC
It is a problem in the way LibreOffice implements OpenGL rendering.
You can see from this meta bug that there are many problems related to it: https://bugs.documentfoundation.org/showdependencytree.cgi?id=93529&hide_resolved=1

If problems are caused by bad drivers, we blacklist the drivers. But many problems need to be fixed on the LibreOffice side.

*** This bug has been marked as a duplicate of bug 106311 ***
Comment 11 Timur 2019-03-28 10:21:29 UTC

*** This bug has been marked as a duplicate of bug 121615 ***