Bug Hunting Session
Bug 116600 - Character Spacing has a minimum limit at -2.0pt (regression)
Summary: Character Spacing has a minimum limit at -2.0pt (regression)
Status: RESOLVED DUPLICATE of bug 107405
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2018-03-24 09:00 UTC by Maurizio M. Gavioli
Modified: 2018-04-08 03:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maurizio M. Gavioli 2018-03-24 09:00:43 UTC
Description:
In Writer and Calc, the "Spacing" value in "Format | Character | Position" dialogue box is limited to the minimum value of -2.0pt.

Steps to Reproduce:
1. Open a Writer or Calc document
2. Select a few characters
3. Choose "Format | Character | Position"
4. Enter a Spacing value lower than -2 pt, e.g. -10pt
5. Tab away from the Spacing text box or select OK

Actual Results:  
The Spacing value is raised at the minimum value of -2.0 pt

Expected Results:
The Spacing value should remain as entered or capped at a much lower value (100pt?).


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Previous versions (before 5) had no limit (or a much higher limit). There seems to be no upper limit (a value of 1000pt is accepted):

A much larger minimum limit (or no limit) is important for leaflets or similar in which large font sizes are often used (72pt and above) and where a tracking of -2 pt is practically ineffective.


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 Regina Henschel 2018-03-24 12:55:52 UTC
In version 4 it was named "condensed" and the limit had been relative to font-size, about 1/6.
Version: 4.5.0.0.alpha0+
Build ID: 40b1e8266e47792d354cd457c652bfb0f0a21e69
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-02-11_00:13:43
Locale: de_DE

In version 5.4 it is named "spacing" with negative values and shows the described problem. Version: 5.4.3.2 (x64)
Build ID: 92a7159f7e4af62137622921e809f8546db437e5
CPU threads: 8; OS: Windows 6.19; UI render: default; 
Locale: de-DE (de_DE); Calc: CL
Comment 2 V Stuart Foote 2018-03-24 13:52:33 UTC

*** This bug has been marked as a duplicate of bug 107405 ***