Bug 116621 - UI: No description for the different border line-styles
Summary: UI: No description for the different border line-styles
Status: RESOLVED DUPLICATE of bug 101886
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.7.2 release
Hardware: All All
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Borders-Tab
  Show dependency treegraph
 
Reported: 2018-03-25 10:08 UTC by Telesto
Modified: 2018-03-25 15:04 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-03-25 10:08:56 UTC
Description:
No description for the different (table/page) border line-styles (it has for textboxes borders)

Steps to Reproduce:
1. Open Writer
2. Format -> Page -> Borders tab
3. Click the drop down box Line Style -> No description.


Actual Results:  
No description

Expected Results:
Should have a description (makes it easier to differentiate) would be more consistent (textbox borders have a description)



Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.1.0.0.alpha0+
Build ID: dd4f1b1bd31daf080dc0420524712dc244e539b5
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-03-20_23:26:38
Locale: en-US (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 V Stuart Foote 2018-03-25 14:27:58 UTC
Confirmed on Windows build
Version: 6.0.2.1 (x64)
Build ID: f7f06a8f319e4b62f9bc5095aa112a65d2f3ac89
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
Locale: en-US (en_US); Calc: CL

The listbox of border styles do not receive tool tip/descriptions.

https://opengrok.libreoffice.org/xref/core/cui/uiconfig/ui/borderpage.ui#175
https://opengrok.libreoffice.org/xref/core/svx/source/dialog/dlgctrl.cxx#1083

With local help installed and extended tips checked enabled. The widgets (Calc & Writer) take Paragraph help articles:

https://opengrok.libreoffice.org/xref/help/source/text/shared/01/05030500.xhp#54
https://opengrok.libreoffice.org/xref/help/source/text/shared/01/05030500.xhp#34

But the LB in the Borders tab of the Paragraph dialog do not have any annotation describing the line (or its bitmap) exposed to the UI
Comment 2 Telesto 2018-03-25 15:04:10 UTC
Oops, already reported multiple times.

*** This bug has been marked as a duplicate of bug 101886 ***