Bug 116627 - EDITING / VIEWING underline is too fat / bold
Summary: EDITING / VIEWING underline is too fat / bold
Status: RESOLVED DUPLICATE of bug 68573
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-25 19:51 UTC by willemijns
Modified: 2018-03-26 20:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
LO ubuntu sample (132.73 KB, image/png)
2018-03-25 19:52 UTC, willemijns
Details
display diff between LO and Wordpad (40.84 KB, image/png)
2018-03-26 20:18 UTC, willemijns
Details

Note You need to log in before you can comment on or make changes to this bug.
Description willemijns 2018-03-25 19:51:42 UTC
Description:
underlined comma g y p q or j are stiked

Steps to Reproduce:
1. Use a Windows default font 
2. Underline text with comma, g y p q or j inside.
3.

Actual Results:  
comma letters , g y p q or j are stiked... not if you import the same document 
in M$ Word online and i suppose M$ Word software.





Expected Results:
underline not need to strike letters.


Reproducible: Always


User Profile Reset: No



Additional Info:
Same kind of comment made on https://ask.libreoffice.org/en/question/59890/underline-spacing/

Same comment can be made on linux version with unbuntu, dejavu sans or lato   font names... 


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 willemijns 2018-03-25 19:52:48 UTC
Created attachment 140878 [details]
LO ubuntu sample
Comment 2 Dieter Praas 2018-03-26 12:24:43 UTC
Can you give an example how it should looks like?
Comment 3 V Stuart Foote 2018-03-26 16:45:55 UTC
Underlining in LO is a synthetic calculated generically from the font height reported by font metric. Underline position is _not_ extracted from the font metrics where a conscientious font designer can specify where underlining should be applied.

The strike through of descenders are annoying, as are variable positioning and widths when multiple fonts are used in an underlined sentence, refactoring would be needed to improve this.

*** This bug has been marked as a duplicate of bug 68573 ***
Comment 4 willemijns 2018-03-26 20:18:25 UTC
Created attachment 140892 [details]
display diff between LO and Wordpad

Hummmmmmm.... wordpad is able to "unhide" bottoms pixels of letters which can cause troubles.. LO can do that too by knowing position of well-known and used fonts no ?
Comment 5 V Stuart Foote 2018-03-26 20:27:37 UTC
(In reply to willemijns from comment #4)
> Created attachment 140892 [details]
> display diff between LO and Wordpad
> 
> Hummmmmmm.... wordpad is able to "unhide" bottoms pixels of letters which
> can cause troubles.. LO can do that too by knowing position of well-known
> and used fonts no ?

Nope! But in general typography would be better to be able to manually assign "position" the underline, or to read the underline "recommendation" from each of the fonts in the selected text/paragraph and apply the greatest of them as underline. And stroke weight would need to be handled. 

But any discussion belongs on the dupe bug 68573