Bug Hunting Session
Bug 116638 - MacOS: Unable to use my OpenGPG keys on MacOS
Summary: MacOS: Unable to use my OpenGPG keys on MacOS
Status: RESOLVED DUPLICATE of bug 115538
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-26 16:35 UTC by Tony Kinyua
Modified: 2018-03-27 14:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tony Kinyua 2018-03-26 16:35:10 UTC
Description:
Am running mac osx 10.13.3 with LO 6.1.0.0.alpha0+ Master and GPG Suite 2018.1 (gpgtools.org).

I have an issue with Digital Signatures. After raising the issue on https://bugs.documentfoundation.org/show_bug.cgi?id=89037#c9 I was advised to try and test on Master and the situation remains the same.

Basically no Digital signatures are listed in File/Digital Signatures/Digital Signatures even though I have a valid OpenPGP key (Usable in Mail.app).

Clicking on Start Certificate manager, I get an error "Could not find any certificate manager".

Documentation is scanty on the process involved in Mac OS but from reviewing what the official documetation describes (Windows) it seems LO is unable to pick  keys/certificates from the GPG Suite or even recognize the suite as a valid certificate manager.

Am willing to try out any leads, pointers that may be availed.

Steps to Reproduce:
1. Save document on Mac OS LO
2. Go to File/Digital Signatures/Digital Signatures.
3. Click on Start Certificate Manager.

Actual Results:  
Nothing is listed on the Digital Signatures.
An error is displayed on clicking Start Certficate Manager. "Could not find any certificate manager"

Expected Results:
List the keys in GPG Keychain and be able to appy them to the current document.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.1.0.0.alpha0+
Build ID: a488c7ad2763b944713997911c1ddb0315d8c93f
CPU threads: 4; OS: Mac OS X 10.13.3; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2018-03-26_00:38:29
Locale: en-GB (en_GB.UTF-8); Calc: group


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 Thorsten Behrens (CIB) 2018-03-26 22:46:27 UTC
Hmm, so I had it working with a comparable setup end of last year (slightly older OSX, and GPGTools versions). I presume GPG keys work just fine in emails?
Comment 2 Tony Kinyua 2018-03-27 08:54:09 UTC
(In reply to Thorsten Behrens (CIB) from comment #1)
> Hmm, so I had it working with a comparable setup end of last year (slightly
> older OSX, and GPGTools versions). I presume GPG keys work just fine in
> emails?

Just sent @THB a signed reply from Mail App to show GPG keys working. Didnt know how to CC the other users directly from the email client.
Comment 3 Alex Thurgood 2018-03-27 14:17:10 UTC

*** This bug has been marked as a duplicate of bug 115538 ***