Download it now!
Bug 116644 - LO Crash on print
Summary: LO Crash on print
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.2.1 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-26 21:41 UTC by admfubar
Modified: 2018-04-09 08:15 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description admfubar 2018-03-26 21:41:51 UTC
Description:
Random print crashing when printing writer document. Inconsistent crashes. Seems to related to documents created in previous versions. Will print the first page of a multipage document then crash. I am printing to a network printer on windows.

LO 6.0.1.1 (64 bit), Win 7 Pro SP1

Actual Results:  
Have not been able to pin down what steps are needed. Will update this as soon as i can

Expected Results:
N/A


Reproducible: Sometimes


User Profile Reset: Yes



Additional Info:
Version: 6.0.1.1 (x64)
Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
CPU threads: 4; OS: Windows 6.1; UI render: default; 
Locale: en-US (en_US)



User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 Dieter 2018-03-27 07:07:19 UTC
Would also be helpful to add a crash report or crash signature, if possible.
Comment 2 Xisco Faulí 2018-03-27 09:51:47 UTC
Probably a dupe of bug 115649 or bug 115221
Comment 3 Xisco Faulí 2018-03-27 09:51:57 UTC Comment hidden (obsolete)
Comment 4 Ray123 2018-04-05 04:19:11 UTC
I can confirm this bug, i tested it in writer and draw module, just open an existing document, print it and after the print dialog closes the program crash without any notice.
Win7/64 and LO 6.0.2.1
Comment 5 Dieter 2018-04-05 08:42:20 UTC
(In reply to Ray123 from comment #4)
> I can confirm this bug, i tested it in writer and draw module, just open an
> existing document, print it and after the print dialog closes the program
> crash without any notice.
> Win7/64 and LO 6.0.2.1

Buovjaga, are these informations sufficent to change the status to NEW?
Comment 6 Buovjaga 2018-04-05 12:38:58 UTC
(In reply to Ray123 from comment #4)
> I can confirm this bug, i tested it in writer and draw module, just open an
> existing document, print it and after the print dialog closes the program
> crash without any notice.
> Win7/64 and LO 6.0.2.1

As bug 115649 is a suspected duplicate, please everyone test with the just-released 6.0.3
Comment 7 Andreas 2018-04-08 14:18:11 UTC
LO Writer crashes always after printing (either ODT and DOC), not randomly. Printer (Kyocera P2035d) receives the printing command and prints, LO crashes immediately after that.
Comment 8 Dieter 2018-04-08 15:34:38 UTC
Andreas, what version of LO do you use? You can copy and past the informations from Help => About LibreOffice
Comment 9 Ray123 2018-04-09 07:13:45 UTC
I tested in LO 6.0.3.2 and it looks like this bug is solved. No crash after printing
Comment 10 Dieter 2018-04-09 08:15:06 UTC
(In reply to Ray123 from comment #9)
> I tested in LO 6.0.3.2 and it looks like this bug is solved. No crash after
> printing

So I close this as RESOLVED WORKSFORME.