Bug Hunting Session
Bug 116665 - Cannot pin recent documents to the LibreOffice "generic" task bar Jumplist icon
Summary: Cannot pin recent documents to the LibreOffice "generic" task bar Jumplist icon
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0.2.1 release
Hardware: x86-64 (AMD64) Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: implementationError, needsUXEval
Depends on:
Blocks:
 
Reported: 2018-03-27 17:46 UTC by Colin
Modified: 2018-11-28 14:10 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Colin 2018-03-27 17:46:43 UTC
Installed over 5.4.5.1
Removed "existing" taskbar and start menu icons which may have been leftovers from the earlier installation an it was giving me the "banned" symbol when trying to pin a document. Pinned the latest installed version from programme menu to start menu and task bar.
Attempting to drag and drop a document to pin it to the new task bar icon gives the alert "pin to libre office" but it is not available when right clicking the icon.
Comment 1 V Stuart Foote 2018-03-28 04:15:45 UTC
Can not confirm => WFM

On Windows 10 Pro 64-bit en-US (ver 1709) with
Version: 6.0.2.1 (x64)
Build ID: f7f06a8f319e4b62f9bc5095aa112a65d2f3ac89
CPU threads: 8; OS: Windows 10.0; UI render: default; 
Locale: en-US (en_US); Calc: CL

Have Classic Shell 4.3.1 Classic Start installed.

Pinned launchers show Jump Lists on Start Menu, and Classic Start menu; and launchers pinned to Taskbar will show Jump List as well as to pin a drag-n-drop of supported file types.  The pinned and recent items will survive an OS "Clear recent items list"; and a pinned item will change to a recent item when unpinned, and that recent item can then be "removed from the list".

This is normal correct Windows 7 Jump List behavior and LibreOffice seems to comply well.
Comment 2 Colin 2018-03-28 04:50:09 UTC
(In reply to V Stuart Foote from comment #1)
> Can not confirm => WFM
> 
> On Windows 10 Pro 64-bit en-US (ver 1709) with
> Version: 6.0.2.1 (x64)
> Build ID: f7f06a8f319e4b62f9bc5095aa112a65d2f3ac89
> CPU threads: 8; OS: Windows 10.0; UI render: default; 
> Locale: en-US (en_US); Calc: CL
> 
> Have Classic Shell 4.3.1 Classic Start installed.
> 
> Pinned launchers show Jump Lists on Start Menu, and Classic Start menu; and
> launchers pinned to Taskbar will show Jump List as well as to pin a
> drag-n-drop of supported file types.  The pinned and recent items will
> survive an OS "Clear recent items list"; and a pinned item will change to a
> recent item when unpinned, and that recent item can then be "removed from
> the list".
> 
> This is normal correct Windows 7 Jump List behavior and LibreOffice seems to
> comply well.

Jump and recent documents for everything on the task bar e3xcept Libre Office function as expected. Classic start and Start also function according to plan for everything except Libre Office. If I right click the LO Generic Classic and Start tabs it shows nothing but launch and pin. If I right click the Classic and Start Calc tab it shows only the recently launched items.
Perhaps its an install over v.5 issue.
Comment 3 Colin 2018-03-28 05:38:52 UTC
Just tried to pin a writer doc to the task bar icon. Only place it manifests is on the Classic CALC tab. Something is happening, just not the right thing.
Would it be worth uninstalling v.6 and reinstalling? In that manner it won't be reinstalling over v.5 and might make a difference.
Comment 4 Colin 2018-03-29 12:54:54 UTC
I have uninstaled and completely removed all traces of Libre Office from program, AppData and registry. Uninstall does not remove the taskbar tab and I manually removed it.
Following a completely fresh install, whatever it is that is left behind by the uninstall, enables the newly triggered LO "start" icon to immmediately resize and locate itself to the former position when the traditional menu icon is selected for "pin to start". Something is left behind by the uninstall.

I also now see the confusion surrounding VSF's reply.

Perhaps I never made it clear enough that I was attempting to pin the documents to the GENERIC Libre Office taskbar tab NOT a libre CALC taskbar tab - I only had the generic LO tab pinned. Previously, I'm certain I could pin any Libre document to the generic LO tab and it would present me with all the pinned documents. Am I mistaken?

As an afterthought, I just pinned the CALC tab to the taskbar and can confirm the items previously pinned (but never present) on the Generic tab now appear on the CALC tab.

Surely, if we now have to have all the LO elements pinned to the taskbar there's not a particularly valid reason for ever bothering to pin the generic tab.

The quickstart (loaded on startup) LO icon does and only ever has presented a list of the LO elements when that is right-clicked.

Not convinced activating the quick start tray, right-clicking the LO icon and then clicking the element tab in the presented list is that much of a shortcut. If right-clicking the element tab presented the pinned and recently opened documents, it probably still isn't as fast as simply activating the Generic LO tab and then selecting from the recently opened list or opening the document folder and scanning all the available documents.

If any of my observations should be "new feature" requests please advise.
Comment 5 V Stuart Foote 2018-03-29 14:18:09 UTC
Adjusting title and confirming. However, NOTABUG

As LibreOffice support for Windows Jump Lists were implemented (bug 35785), each module receives its own associated document type. The generic has nothing associated with it other than launching LO to StartCenter if LO is not running, or bringing up the last launched LO module if running.

For now--simple work around--DON'T pin the generic. It has limited function.

Dev choice to either remove the pinned generic when another module launcher is pinned--or figure some way to not pin the generic.
Comment 6 Colin 2018-03-29 14:33:19 UTC
Is there any significance to what appears to be some residual parameters after uninstall and forced removal of all LO files, folders and registry entries that assign the previous size and location of the earlier installation "start" menu icon for the "new" installation - or is that more likely to be a Win10 issue?

Does the status need to be changed or is that further down the line?
Comment 7 Heiko Tietze 2018-11-28 06:57:28 UTC
Stuart, as Windows user could you please make a decision on this issue. NAB sounds okay.
Comment 8 V Stuart Foote 2018-11-28 14:10:05 UTC
As implemented for bug 35785 each LO module receives its own Windows start/taskbar Jump list. And the pined LibreOffice "generic" only receive the StartCenter view--enabled when no other modules are active.

Behavior is as intended, with minimal returns to work involved with trying to consolidate. Just let it be.

IMHO => WF