Bug 116670 - Manage Names Dialog does not repaint after resize
Summary: Manage Names Dialog does not repaint after resize
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: x86-64 (AMD64) All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: implementationError
Depends on:
Blocks: Cell-Name
  Show dependency treegraph
 
Reported: 2018-03-28 04:27 UTC by russell
Modified: 2021-04-22 10:35 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Image of manage name repaint from attached spreadsheet (22.58 KB, image/jpeg)
2018-03-30 00:10 UTC, russell
Details
Manage name repaint sample spreadsheet per request (12.88 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-03-30 00:16 UTC, russell
Details

Note You need to log in before you can comment on or make changes to this bug.
Description russell 2018-03-28 04:27:16 UTC
Description:
When the Manage Names dialog is first opened and the frame grabbed at the bottom to make the list area larger, the list items are not repainted.  This happens only for the "Range or formula expression" column. When the dialog was first opened, there were 11 items visible in the list. Those same 11 items are still visible, but no new items are painted after the 11th. Grabbing the vertical scroll bar causes the items to be repainted.

This happens on Windows and Linux.

Steps to Reproduce:
1. Click Manage Names.
2. Grab the bottom right corner of the frame and drag to make larger.
3. The items in the Range or Formula expression column are not repainted. When the dialog was first open, there were 11 items visible in the list. Those same 11 items are visible, but no new items are painted after the 11th in the Range or Formula column.
4. Grab the vertical scroll bar and drag it up and down and the column is repainted.


Actual Results:  
 1 Total $'2000'.$O$100   2000
 2 Total $'2001'.$O$100   2001
 3 Total $'2002'.$O$100   2002
 4 Total $'2003'.$O$100   2003
 5 Total $'2004'.$O$100   2004
 6 Total $'2005'.$O$100   2005
 7 Total $'2006'.$O$100   2006
 8 Total $'2007'.$O$100   2007
 9 Total $'2008'.$O$100   2008
10 Total $'2009'.$O$100   2009
11 Total $'20010'.$O$100  2010
12 Total                  2011
13 Total                  2012
14 Total                  2013
etc.

Expected Results:
 1 Total $'2000'.$O$100   2000
 2 Total $'2001'.$O$100   2001
 3 Total $'2002'.$O$100   2002
 4 Total $'2003'.$O$100   2003
 5 Total $'2004'.$O$100   2004
 6 Total $'2005'.$O$100   2005
 7 Total $'2006'.$O$100   2006
 8 Total $'2007'.$O$100   2007
 9 Total $'2008'.$O$100   2008
10 Total $'2009'.$O$100   2009
11 Total $'20010'.$O$100  2010
12 Total $'20011'.$O$100  2011
13 Total $'20012'.$O$100  2012
14 Total $'20013'.$O$100  2013
etc.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
Comment 1 Buovjaga 2018-03-29 19:18:48 UTC
Please attach an example file so it is quicker for everybody to test.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the document.
Comment 2 russell 2018-03-30 00:10:50 UTC
Created attachment 140966 [details]
Image of manage name repaint from attached spreadsheet
Comment 3 russell 2018-03-30 00:16:00 UTC
Created attachment 140967 [details]
Manage name repaint sample spreadsheet per request

Open manage-name-repaint spreadsheet.
Open manage name dialog.
Grab lower right hand corner and drag to resize. 
The results should look like the attached image.

This happens with libreoffice 6.0.2.1 on Linux and Windows.

On libreoffice 4.3.3.2 (which in on LMDE), the list does not resize at all.
Comment 4 Buovjaga 2018-03-30 15:48:53 UTC
Reproduced. Sheet - Named ranges and expressions - Manage.

The dialog used to be non-resizable. The change must have brought this behaviour with it. This is already seen in 5.0.2. In 4.4.7, the dialog can be resized, but the field with the names does not get bigger at all.

Weird that the "Range and formula expression" really is blank even when you select it.

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: 9c459fd919cb8199a69fc2d630742930e533285b
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on March 29th 2018
Comment 5 QA Administrators 2019-03-31 02:54:14 UTC Comment hidden (obsolete)
Comment 6 Bill 2019-12-29 03:26:50 UTC
This problem remains in Version: 6.2.8.2 (x64) Build ID: f82ddfca21ebc1e222a662a32b25c0c9d20169ee on Windows 8.1.

The problem is a bit more insidious than it may seem at first glance.

If the user increases the height of the 'Manage Names' window and then clicks on one of the newly exposed entries in the list which, incorrectly, is blank in the 'Range or formula expression' column, that field is also blank in the corresponding list-box control below. If the panel at the bottom is updated, such as to change the value of 'Name' or change the scope, and OK is eventually clicked, the 'Range or Formula expression' associated with the name is wiped out creating #REF! errors where the name is used. Even just clicking in the 'Range or Formula expression' input control without touching the keyboard results in this behavior. It's very easy to do this by accident as the user is focusing on the field they are changing, not the other fields, so may not notice the blank 'Range or Formula expression' and is even less likely to understand the implications of the blank field.

A workaround _seems_ to be to force a refresh by either scrolling through to the bottom of the list BEFORE resizing or reducing the window (if needed) after resizing so the list doesn't fit and then scrolling through to the bottom of the list. Either the mouse or keyboard can be used to scroll.
Comment 7 Andreas Heinisch 2021-04-22 10:35:08 UTC
I can reproduce the error with:
Version: 6.0.2.1 (x64)
Build-ID: f7f06a8f319e4b62f9bc5095aa112a65d2f3ac89
CPU-Threads: 6; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: CL

but not with:
Version: 6.4.7.2 (x64)
Build-ID: 639b8ac485750d5696d7590a72ef1b496725cfb5
CPU-Threads: 6; BS: Windows 10.0 Build 19042; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: CL

Version: 7.1.0.3 (x64) / LibreOffice Community
Build ID: f6099ecf3d29644b5008cc8f48f42f4a40986e4c
CPU threads: 6; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 0e621eda01eb942bc46d32abc2f9e0e76ef16313
CPU threads: 6; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-US
Calc: CL