Download it now!
Bug 116696 - Update the fallback strategy and replace Galaxy by Colibre
Summary: Update the fallback strategy and replace Galaxy by Colibre
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Heiko Tietze
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Icon-Themes
  Show dependency treegraph
 
Reported: 2018-03-29 15:23 UTC by Heiko Tietze
Modified: 2018-06-12 21:14 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Tietze 2018-03-29 15:23:19 UTC
Galaxy is out-dated, not maintained, and has on SVG support. So we should replace it with a complete set, once Colibre contains all items. 

Since Industrial is also not maintained (and for some reason not listed under Tools > Options > View > Icon Styles) the proposal is to clean-up the function a bit further.
Comment 1 Heiko Tietze 2018-03-29 15:46:49 UTC
Patch at https://gerrit.libreoffice.org/#/c/52118/
Comment 2 Xavier Van Wijmeersch 2018-03-29 16:55:48 UTC
I can understand there is a need for cleanup or anything else but i dislike breeze; sfr and also Colibre. I am art lover and love some 3d and not flat design because of plasma and other design form. So i hope tango can be saved as icon style in tools => options => view => icon style

regards
Comment 3 Heiko Tietze 2018-03-29 17:03:38 UTC
The plan is to make the legacy themes available as extension. But since there is no maintainer Tango's days are numbered.
Comment 4 Jean-Baptiste Faure 2018-03-31 17:31:14 UTC
Valid enhancement request.

Best regards. JBF
Comment 5 Heiko Tietze 2018-04-11 17:38:12 UTC
*** Bug 116916 has been marked as a duplicate of this bug. ***
Comment 6 andreas_k 2018-05-03 13:03:12 UTC
Colibre has now ALL tango and galaxy icons included.

Colibre
3.300 icons + 1,500 linked files = 4.800 icons

Galaxy
3.900 icons + 150 lined files = 4.050 icons
Comment 7 V Stuart Foote 2018-05-03 14:23:15 UTC
+1 to proceed

And IMHO believe the work integrating Karasa Jaga [1] 3D to core (bug 117342) would compliment this change, for those inclined toward 3D themes, and effectively permit us to retire Galaxy and Oxygen (to a legacy by "extension" status as Heiko promotes).

=-ref-=
[1] https://github.com/rizmut/libreoffice-style-karasa-jaga/blob/master/preview.png
Comment 8 Heiko Tietze 2018-05-06 10:12:23 UTC
Done with https://gerrit.libreoffice.org/#/c/53092/
Comment 9 Yousuf Philips (jay) (retired) 2018-06-12 09:05:59 UTC
(In reply to Heiko Tietze from comment #0)
> Galaxy is out-dated, not maintained, and has on SVG support. So we should
> replace it with a complete set, once Colibre contains all items. 

FYI, Regina is still maintaining Galaxy and choosing a new fallback isnt just whether it has all items, it should also depend on how well the fallback appears in the child themes and how tested these icon metaphors compare with the previous fallback.
Comment 10 andreas_k 2018-06-12 09:19:02 UTC
The idea was to have Colibre for windows users, as it had all items from galaxy (also available in svg) and the feedback was very positive Colibre was choose as fallback.

I don't see any reason why Galaxy shouldn't be replaced as fallback theme.
Comment 11 Thomas Lendo 2018-06-12 17:28:20 UTC
I wouldn't obsess about it and go with Colibre as fallback icon set for the OS it's planned to use it for all systems.

If it works not well and many complains come from users, we can revert it.
Comment 12 V Stuart Foote 2018-06-12 21:14:18 UTC
*** Bug 118123 has been marked as a duplicate of this bug. ***