Bug 116751 - personalized palette files could not be imported (*.soc or *.sog)
Summary: personalized palette files could not be imported (*.soc or *.sog)
Status: RESOLVED DUPLICATE of bug 107079
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0.2.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HelpGaps-NewFeatures
  Show dependency treegraph
 
Reported: 2018-04-02 13:30 UTC by roumanet
Modified: 2018-04-02 20:41 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description roumanet 2018-04-02 13:30:22 UTC
Description:
Help file explains there is a menu to import/export colors palette.
It was true until 5.4 and 6.0 version of LibreOffice.
Now I cannot use my corporate colors !

Before these versions, palettes could be created/imported/exported with
menu ► format ► Area
By the way, 
menu ► Format ► Textbox and shapes (doesn't help too)

Steps to Reproduce:
1.menu ► format ► Area
2.
3.

Actual Results:  
Nothing in the menu

Expected Results:
having an importing/exporting palettes


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:56.0) Gecko/20100101 Firefox/56.0
Comment 1 roumanet 2018-04-02 13:43:03 UTC
Searching on the web and found a workaround : save your *.soc file in
C:\Users\XXXXX\AppData\Roaming\LibreOffice\4\user\config

Restart LibreOffice : the palette is back again (but not editable).
Comment 2 V Stuart Foote 2018-04-02 20:41:17 UTC
This was by design--Help is lagging a bit. 

Rational is that managed palettes will be installed by IT. While composing individual palettes are best handled external to LO. In the case of your corporate colors--a .soc containing them would be added to program <install directory>/share/palette. 

In addition, per user the Custom and the Document palettes will pick up any custom colors used in a current session. Both are transient, Custom will be written to User profile while Document is written into the ODF.

Also for general project etiquette: please do not confirm your own issue(s), it obscures them from proper QA review.

*** This bug has been marked as a duplicate of bug 107079 ***