Download it now!
Bug 116754 - When saving a Writer document As RTF header text from p.2 appears in a footnote on p.1
Summary: When saving a Writer document As RTF header text from p.2 appears in a footno...
Status: RESOLVED DUPLICATE of bug 116753
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, filter:rtf, regression
Depends on:
Blocks: RTF-Header-Footer
  Show dependency treegraph
 
Reported: 2018-04-02 14:14 UTC by Bernard Moreton
Modified: 2019-07-12 10:05 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample test file in RTF format (5.08 KB, application/rtf)
2018-04-02 14:16 UTC, Bernard Moreton
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bernard Moreton 2018-04-02 14:14:33 UTC
Description:
After opening the sample RTF, which is correctly rendered, if the file is saved s RTF (I used a new filename in testing), the page break is lost (see Bug 116753) and the header text from p.2 is put in a footnote on p.1.  On re-opening the saved file, the distortions are seen.

Steps to Reproduce:
1. Open the sample uploaded RTF
2. Save As an RTF and close
3. Re-open save RTF

Actual Results:  
Header text from p.2 is in footnote on p.1

Expected Results:
Better handling.  Saving As RTF may lose some formatting (in this case, there's no change in page style after p.1), but page break should have been retained, and the header text of p.2 at least put at the top of p.2 - but since opening the original showed a header change correctly, perhaps a page style change should have been forced?


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/538.1 (KHTML, like Gecko) QupZilla/1.8.9 Safari/538.1
Comment 1 Bernard Moreton 2018-04-02 14:16:00 UTC
Created attachment 141032 [details]
Sample test file in RTF format
Comment 2 Bernard Moreton 2018-04-02 15:32:48 UTC
This report came from an observation against bug 92013
Comment 3 Dieter 2018-04-02 17:04:02 UTC
If I open the document, I have footnote 3 on page 2. The text of the footnote is "Header text". I saved th document and reopened it. Page break is lost and so footnote 3 is on the first page. I think it's only a duplicae of bug 116573, but nothing else.
Comment 4 Buovjaga 2018-04-13 10:59:12 UTC
(In reply to Dieter Praas from comment #3)
> If I open the document, I have footnote 3 on page 2. The text of the
> footnote is "Header text". I saved th document and reopened it. Page break
> is lost and so footnote 3 is on the first page. I think it's only a duplicae
> of bug 116573, but nothing else.

Why would it be a duplicate of "Opening multiple documents at once on Mac sometimes fails"?
Comment 5 Dieter 2018-04-13 11:15:45 UTC
(In reply to Buovjaga from comment #4)

> Why would it be a duplicate of "Opening multiple documents at once on Mac
> sometimes fails"?

I obviously entered the wrong bug number, I meant bug 116753, which I added in "See also"
Comment 6 geraldg 2018-05-06 15:51:35 UTC
I can confirm the bug with Version: 6.1.0.0.alpha1 /deb64
Comment 7 Xisco Faulí 2018-05-07 14:25:46 UTC
Reproduced in

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.10; Render: default; 

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

but not in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 9 QA Administrators 2019-07-08 02:48:27 UTC Comment hidden (obsolete)
Comment 10 Bernard Moreton 2019-07-08 14:35:44 UTC
I can confirm that the bug is still present in the current version:

Version: 6.2.4.2
Build ID: 1:6.2.4-0ubuntu0.18.04.1~lo1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
Calc: threaded
Comment 11 Dieter 2019-07-12 10:05:17 UTC

*** This bug has been marked as a duplicate of bug 116753 ***