Download it now!
Bug 116793 - PDF exporting with annotations shows incomplete slides miniatures
Summary: PDF exporting with annotations shows incomplete slides miniatures
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.3.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pdf
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2018-04-04 12:03 UTC by Andy
Modified: 2019-03-16 20:13 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
tnhis is the original impress doc (593.93 KB, application/vnd.oasis.opendocument.presentation)
2018-04-04 12:04 UTC, Andy
Details
This is the pdf file. On page 2 the bitmap is missing in the slide (603.52 KB, application/pdf)
2018-04-04 12:05 UTC, Andy
Details
real presentation to be exported in pdf with annotations (4.24 MB, application/vnd.oasis.opendocument.presentation)
2018-04-05 08:44 UTC, Andy
Details
first pdf export (153.99 KB, application/pdf)
2018-04-05 08:51 UTC, Andy
Details
second pdf export (295.98 KB, application/pdf)
2018-04-05 08:53 UTC, Andy
Details
third pdf export (685.73 KB, application/pdf)
2018-04-05 09:02 UTC, Andy
Details
A full presentation with notes in a lot of pages, used to exemplify the currupted pdf rendering (11.32 MB, application/vnd.oasis.opendocument.presentation)
2018-05-16 10:49 UTC, Andy
Details
The PDF rendering result. You don't need to delve deep into it to see the problem: first 2 pages are black, third page is missing all images (436.44 KB, application/pdf)
2018-05-16 10:51 UTC, Andy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andy 2018-04-04 12:03:04 UTC
Description:
1. Create an impress presentation, putting some bitmap images in the slides
2. Write some notes to the slides, in Notes (or annotations, I do not know which one is used in English) view mode
3. Now export as a PDF with the flag "export annotations (notes)" enabled
4. open your pdf. In the pages that combine each slide with its annotations, slides are corrupted. More precisely, most bitmap images placed in them are completely missing.

Steps to Reproduce:
1. Create an impress presentation, putting some bitmap images in the slides
2. Write some notes to the slides, in Notes (or annotations, I do not know which one is used in English) view mode
3. Now export as a PDF with the flag "export annotations (notes)" enabled
4. open your pdf. In the pages that combine each slide with its annotations, slides are corrupted. More precisely, most bitmap images placed in them are completely missing

Actual Results:  
Most of the bitmaps inserted in the slides are missing in the pdf file where slides are half page and annotations are shown below

Expected Results:
the slide miniature above the annotations in the pdf file should be identical to the actual slide of the presentation


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 Andy 2018-04-04 12:04:21 UTC
Created attachment 141078 [details]
tnhis is the original impress doc

this is a sample presentation, with just one slide with a text object and a bitmap, to be compared with the PDF
Comment 2 Andy 2018-04-04 12:05:01 UTC
Created attachment 141079 [details]
This is the pdf file. On page 2 the bitmap is missing in the slide
Comment 3 Timur 2018-04-04 17:19:51 UTC
No repro Win LO 6.0.2 and libo-master~2018-03-30_00.00.18_LibreOfficeDev_6.1.0.0.alpha0_Win_x86
Comment 4 Andy 2018-04-05 08:43:40 UTC
I am attaching a real, more large document to show the problem now on 6.0.3.2. Here when exporting in pdf format with annotations almost all images are lost, at least for me.
Comment 5 Andy 2018-04-05 08:44:20 UTC
Created attachment 141112 [details]
real presentation to be exported in pdf with annotations
Comment 6 Andy 2018-04-05 08:49:10 UTC
I am now noticing that the process has a random component, who knows why....
I will now attach 3 consecutive pdf export from the same impress file, which are all defective, but not the same... strange indeed. some comments to outline the differences in result are attached to the files
Comment 7 Andy 2018-04-05 08:51:03 UTC
Created attachment 141114 [details]
first pdf export

this is the worst outcome, the large bitmaps in the first 2 pages are missing, page 3 has NO image at all, and this happens for all the following slides
Comment 8 Andy 2018-04-05 08:53:59 UTC
Created attachment 141115 [details]
second pdf export

first two large images still missing, but now page 3 has its bitmaps. following pages seems ok, but alas page 9 is missing all its many bitmaps except for the one coming from the slide template.
the same happens for page 10
Comment 9 Andy 2018-04-05 09:02:08 UTC
Created attachment 141116 [details]
third pdf export

the third installment is still different: now the large bitmap on page 1 is shown, but still no trace of that on page 2. Contrary to previous pdf, the large "unito-go" large double circle on lower left corner of page 3 is now missing.
Pages 9 and 10 are as bad as in test2.
And, i forgot to mention that the image on upper right corner of page 5 (imperial college, on your bike) is never shown.
If anyone can obtain from the "Presentazione 21-9-2017 - test.odp" file the pdf with annotations export with full correct slide display, please let me know and state precisely your course of action, so that I can try to understand where I go wrong. Thanks
Comment 10 Buovjaga 2018-04-13 11:19:01 UTC
No problem here. Please test with a fresh master build (it has image handling improvements): https://dev-builds.libreoffice.org/daily/master/Win-x86_64@42

Arch Linux 64-bit
Version: 6.0.3.2
Build ID: 6.0.3-1
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: 16b51d73c94f6fcab45695e4353cbe4ee97b52cc
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on April 13th 2018
Comment 11 Andy 2018-05-16 09:40:47 UTC
Hi. I re-tried this with 6.0.4.2 and the result is tragic... most pages strongly corrupted with missing images.
Comment 12 Andy 2018-05-16 09:53:23 UTC
If anybody would like, I can post another attachment odp file and the corresponding pdf rendering
Comment 13 Buovjaga 2018-05-16 10:27:26 UTC
(In reply to Andy from comment #12)
> If anybody would like, I can post another attachment odp file and the
> corresponding pdf rendering

Sure.
Comment 14 Andy 2018-05-16 10:49:39 UTC
Created attachment 142129 [details]
A full presentation with notes in a lot of pages, used to exemplify the currupted pdf rendering
Comment 15 Andy 2018-05-16 10:51:22 UTC
Created attachment 142130 [details]
The PDF rendering result. You don't need to delve deep into it to see the problem: first 2 pages are black, third page is missing all images
Comment 16 Andy 2018-05-16 10:53:49 UTC
Ok: I attached original presentation file and "pdf with notes rendering". the attachment is the real presentation with which I've been troubled lately. All this was made with LO 6.0.4.2
Comment 17 Buovjaga 2018-05-16 12:48:32 UTC
Still no problem even on Windows. Now I'm starting to suspect something. Please copy and paste here the contents of your Help - About. This allows us to know more about your system.

Version: 6.0.4.2 (x64)
Build ID: 9b0d9b32d5dcda91d2f1a96dc04c645c450872bf
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: fi-FI (fi_FI); Calc: group
Comment 18 Andy 2018-05-16 14:59:06 UTC
There you go:
Versione: 6.0.4.2
Build ID: 9b0d9b32d5dcda91d2f1a96dc04c645c450872bf
Thread CPU: 4; SO: Windows 6.1; Resa interfaccia: predefinito; 
Versione locale: it-IT (it_IT); Calc: group
Comment 19 Buovjaga 2018-05-16 15:06:41 UTC
Hmh, Resa interfaccia is predefinito and not GL, so it cannot be an OpenGL glitch :(
Only difference is you have Windows 6.1. Maybe I should test with Windows 7 later, sigh...
Comment 20 Andy 2018-05-16 15:12:18 UTC
Wait... I just installed a separate fresh instance  of the same LO 6.0.4.2 using reisisoft "separate install GUI".
PDF rendering from there does not have the problem.
How to overcome this without losing the many many personalised settings, toolbar modifications, etc. is entirely another matter....
Any hint???
Comment 21 Buovjaga 2018-05-16 16:07:49 UTC
(In reply to Andy from comment #20)
> Wait... I just installed a separate fresh instance  of the same LO 6.0.4.2
> using reisisoft "separate install GUI".
> PDF rendering from there does not have the problem.
> How to overcome this without losing the many many personalised settings,
> toolbar modifications, etc. is entirely another matter....
> Any hint???

Try launching your original instance in Safe mode to see, if it helps. It seems you might have a problem in the user profile of the original instance.
https://wiki.documentfoundation.org/UserProfile

How to preserve your modifications: you could copy a backup of your original profile and then delete each sub-directory in your active profile one by one, each time trying the PDF export. Hopefully the problematic sub-directory is something that does not affect your modifications.
Comment 22 Xisco Faulí 2018-06-18 16:38:13 UTC
Dear Andy,
Thank you for reporting the bug. To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 23 QA Administrators 2019-01-11 15:21:47 UTC Comment hidden (obsolete)
Comment 24 Roman Kuznetsov 2019-03-16 20:13:31 UTC
don't repro in

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 13a260f59e421f3e67845f8f2eb22b8f0f8fcaf0
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-03-11_02:46:09
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded