Bug Hunting Session
Bug 116802 - MAILMERGE CRASH on Mac OS X when creating individual PDF documents
Summary: MAILMERGE CRASH on Mac OS X when creating individual PDF documents
Status: RESOLVED DUPLICATE of bug 116543
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.1.1 release
Hardware: All All
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-04-04 15:36 UTC by Marina Latini (CIB)
Modified: 2018-04-04 17:33 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
source ODS file (9.03 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-04-04 15:37 UTC, Marina Latini (CIB)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marina Latini (CIB) 2018-04-04 15:36:31 UTC
Description:
LibreOffice crashes using mailmerge and exporting the file as PDF individual documents

Steps to Reproduce:
1. Create a new ODT file
2. Insert -> field -> more fields...
3. Select the "Database" tab
4. Click on "browse" and select the "sorgente-test.ods"
5. double click on "sorgente-test.ods"
6. double click on "foglio 1"
7. double click on "field1" "field2" field3"
8. click on close
9. file -> print -> "yes"
10. Select the radiobutton "all records"
11. as "output" select "file" and "save as individual documents"
12. check "generate file name from database"
13. as field select "field1"
14. as path select your destination folder
15. as file format select "PDF"
16. click "ok"

Actual Results:  
LibreOffice crashes and in the destination folder is generated only the first pdf.

Expected Results:
All the PDF are generated and LibreOffice is still running


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Nome modello: Mac mini
Identificatore modello: Macmini6,1
Nome processore: Intel Core i5
Velocità processore: 2,5 GHz
Numero di processori: 1
Numero totale di Core: 2
Cache L2 (per Core): 256 KB
Cache L3: 3 MB
Memoria: 4 GB
Versione Boot ROM: MM61.010B.B00
Versione SMC (sistema): 2.7f0

repro on:
Versione: 6.0.2.1
Build ID: f7f06a8f319e4b62f9bc5095aa112a65d2f3ac89
Thread CPU: 4; SO: Mac OS X 10.12.6; Resa interfaccia: predefinito; 
Versione locale: it-IT (it_IT.UTF-8); Calc: group

repro on:
Versione: 6.0.1.1
Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
Thread CPU: 4; SO: Mac OS X 10.13.3; Resa interfaccia: predefinito; 
Versione locale: it-IT (it_IT.UTF-8); Calc: group


works fine on:
Version: 5.2.5.1
Build ID: 0312e1a284a7d50ca85a365c316c7abbf20a4d22
CPU Threads: 4; OS Version: Mac OS X 10.13.3; UI Render: default; 
Locale: it-IT (en_IT.UTF-8); Calc: group 


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 Marina Latini (CIB) 2018-04-04 15:37:03 UTC
Created attachment 141088 [details]
source ODS file
Comment 2 Xisco Faulí 2018-04-04 17:18:44 UTC
Also reproduced in

Version: 6.1.0.0.alpha0+
Build ID: 2d5ce0e1b233c83f91481cd6b9306ac8de7f5ff8
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 3 Xisco Faulí 2018-04-04 17:33:44 UTC
Regression introduced by 97477ee5e11951a5a25a91b89f1b71a1b78ac8f5, which is the same as in bug 116543.
Closing as RESOLVED DUPLICATED.

*** This bug has been marked as a duplicate of bug 116543 ***