Download it now!
Bug 116829 - Certain JPG Images not rendered correctly when exporting to PDF in LibreOffice 6+ and 5.4+
Summary: Certain JPG Images not rendered correctly when exporting to PDF in LibreOffic...
Status: RESOLVED DUPLICATE of bug 102928
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
5.4.4.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-05 14:50 UTC by dxt.tfg
Modified: 2018-04-05 15:09 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
The problematic JPG image (133.15 KB, image/jpeg)
2018-04-05 14:52 UTC, dxt.tfg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dxt.tfg 2018-04-05 14:50:03 UTC
Description:
When I tried to insert a certain jpg image to a LireOffice document (Writer, Calc and Impress) and then chose export to PDF, the image was distorted. When opening the exported PDF file with Foxit reader, the image was cut off and the color was filled with diagonal grey lines. In some other PDF readers, the image was just a box.

The weird thing is other jpg files were exported correctly, or when the problematic jpg file was converted to png.

This happened on both Linux and Windows, tested with LibreOffice 5.4+ (upto the latest 5.4.2) and 6.0+ (upto the latest 6.0.3.2)

Steps to Reproduce:
1.Open a document in any LibreOffice application (Writer, Calc, Impress)
2.Insert a certain JPG file
3.Choose export to PDF

Actual Results:  
The image in the exported PDF file was not displayed/rendered correctly. When Trying with Other JPG images or converting the problematic JPG file to PNG, everything works file.

Expected Results:
The image in the exported PDF is rendered correctly


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Disabling/Enabling OpenGL and/or OpenCL had no effect


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.9) Gecko/20100101 Goanna/3.4 Firefox/52.9 PaleMoon/27.8.3
Comment 1 dxt.tfg 2018-04-05 14:52:24 UTC
Created attachment 141135 [details]
The problematic JPG image
Comment 2 Aron Budea 2018-04-05 15:09:28 UTC
This is a duplicate of bug 102928, please see that bug report for details.

*** This bug has been marked as a duplicate of bug 102928 ***