Bug 116838 - EDITING Not possible to edit chart from sidebar (steps on comment 4)
Summary: EDITING Not possible to edit chart from sidebar (steps on comment 4)
Status: RESOLVED DUPLICATE of bug 94322
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
5.2 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-06 06:10 UTC by Emil Tanev
Modified: 2022-06-16 05:59 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Emil Tanev 2018-04-06 06:10:44 UTC
Open Writer
Insert a chart
Try to edit the chart using the sidebar/property panel, e.g. checkboxes Title and Subtitle
Issue impossible to edit the chart

https://screencast-o-matic.com/watch/cFf11eDKUn


Version: 6.1.0.0.alpha0+ (x64)
Build ID: d39a8e791618a40328c0f90bece3cc246dcf57f7
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-04-06_00:59:07
Locale: en-US (en_US); Calc: group
Comment 1 Emil Tanev 2018-04-06 06:20:21 UTC
There may be two issues here:
1. Impossibility to edit chart (which I report here)
2. The lagging/overlap of UI elements. This second one seems to happen only after I add the chart but if I click elsewhere and then subsequently select Chart/Chart Area again, I cannot reproduce it.
Comment 2 Laurent BP 2018-04-14 15:09:06 UTC
I can NOT reproduce with:
- Version: 5.4.7.1
Build ID: ef425abf896c652d177000096228d1dbcfe9c7af
CPU threads: 8; OS: Linux 4.13; UI render: default; VCL: gtk2; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group

I CAN reproduce with:
- Version: 6.1.0.0.alpha0+
Build ID: 2c63fcb0cf10c7ce580545576f2bd40dbcdb61d0
CPU threads: 8; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group

When selecting Chart, panel "Elements" is displayed but closed (panel Area and Line are open), but when clicking on + to open it, it disappears (Area, Warp and Position and Size are opened).

With or without Hardware acceleration change the behavior, but Sidebar is still buggy.
Comment 3 Xisco Faulí 2018-04-16 09:49:01 UTC Comment hidden (obsolete)
Comment 4 Xisco Faulí 2018-04-17 14:43:08 UTC
I don't think this is a regression

Steps to reproduce:
1. hide the sidebar ( only icons are displayed )
2. Insert a chart
3. Double click on the chart
4. Click on 'Properties' icon on the sidebar

-> Chart elements on the sidebar don't work

Reproduced back to 

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.13; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)
Comment 5 Timur 2018-05-25 16:44:10 UTC
Seems like editing the chart from the sidebar was changed. 
Up to 6.0.3 was as Emil reported and from 6.0.4 to master it's not possible at all. 
Guess someone disabled it.
Comment 6 Francisco 2018-09-23 20:59:36 UTC
(In reply to Timur from comment #5)
> Seems like editing the chart from the sidebar was changed. 
> Up to 6.0.3 was as Emil reported and from 6.0.4 to master it's not possible
> at all. 
> Guess someone disabled it.

Hi,

I'm also affected by this bug. Also, it looks like a dup of Bug 100180, though it was marked as fixed.
Comment 7 Jean-Baptiste Faure 2018-09-24 06:07:48 UTC
(In reply to Francisco from comment #6)
> [...]
> I'm also affected by this bug. Also, it looks like a dup of Bug 100180,
> though it was marked as fixed.

Probably not. I think this feature is broken again.

Best regards. JBF
Comment 8 Buovjaga 2018-09-24 06:59:49 UTC
*** Bug 103136 has been marked as a duplicate of this bug. ***
Comment 9 Aron Budea 2021-03-31 03:23:15 UTC
*** Bug 115147 has been marked as a duplicate of this bug. ***
Comment 10 Rafael Lima 2022-06-14 14:43:38 UTC
Still repro with

Version: 7.5.0.0.alpha0+ / LibreOffice Community
Build ID: 66b849eab05bb6b696cced84ca90c17ca1bc31dd
CPU threads: 16; OS: Linux 5.13; UI render: default; VCL: kf5 (cairo+xcb)
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
Calc: CL

This bug is also present from within Calc. See Bug 135890 which has a bisected report about this issue.
Comment 11 Aron Budea 2022-06-16 05:58:59 UTC
Let's consolidate these into bug 94322, as they have the same root cause.

*** This bug has been marked as a duplicate of bug 94322 ***