Download it now!
Bug 116897 - Template paths scanned even though specifying a template from command line
Summary: Template paths scanned even though specifying a template from command line
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.2.1 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Templates
  Show dependency treegraph
 
Reported: 2018-04-09 09:57 UTC by rolfofsaxony
Modified: 2019-04-19 08:10 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
simple writer template example (9.42 KB, application/vnd.oasis.opendocument.text-template)
2018-04-09 09:59 UTC, rolfofsaxony
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rolfofsaxony 2018-04-09 09:57:10 UTC
Description:
Loading a template in Writer Version: 6.0.2.1 is desperately slow.
In my experience 10 times slower than Version 5.4 (dev version)


Steps to Reproduce:
1.libreofficedev5.4 --writer -n "/home/rolf/.config/libreoffice/4/user/template/template 1.ott"
2.loffice --writer -n "/home/rolf/.config/libreoffice/4/user/template/template 1.ott"
3.

Actual Results:  
command 1 (lowriter 5.4) takes 4 seconds
command 2 (lowriter 6.0) takes 70-80 seconds

Expected Results:
I'd expect the template to load in roughly the same amount of time.
As it is, it's unbearable.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.181 Safari/537.36 OPR/52.0.2871.40
Comment 1 rolfofsaxony 2018-04-09 09:59:02 UTC
Created attachment 141226 [details]
simple writer template example
Comment 2 rolfofsaxony 2018-04-09 10:26:28 UTC
After more investigation this bug is in 5.4 as well.
The issue is, if you add extra directories to the template Paths.
If the directory in question is virtually empty, the time to find and load the template is relatively quick.
However, if the directory is large, such as your home directory for example, the loading of the template takes forever.
I can only assume that for some reason of other, the program is checking every file in the directory, to see if it is a template or not, even though you have named the template to be opened.
Comment 3 Buovjaga 2018-04-18 12:31:20 UTC
Repro.

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: c8c74a0b4ca6f3a3619f423b6548c80c52392ae0
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on April 15th 2018
Comment 4 QA Administrators 2019-04-19 03:01:41 UTC Comment hidden (obsolete)
Comment 5 rolfofsaxony 2019-04-19 08:08:58 UTC
Seems to have been fixed.

Tested on:
Version: 6.2.1.2
Build ID: 7bcb35dc3024a62dea0caee87020152d1ee96e71
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

Near identical load times