Bug 116901 - The bitmap appears blurred when inserting a bitmap with the scale checkbox checked (and the size set to 100%)
Summary: The bitmap appears blurred when inserting a bitmap with the scale checkbox ch...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Area-Fill-Tab-Bitmap
  Show dependency treegraph
 
Reported: 2018-04-09 16:19 UTC by Telesto
Modified: 2018-04-23 19:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-04-09 16:19:24 UTC
Description:
The bitmap is blurred when inserting it with the scale checkbox checked and the size set to 100%

Steps to Reproduce:
1. Format -> Page -> Area tab
2. Bitmap button -> Select a bitmap. Check the 'scale' checkbox
3. Press -> OK 

Actual Results:  
Blurry image

Expected Results:
Not OK in my opinion 


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
Version: 6.1.0.0.alpha0+
Build ID: 818619b0f2f7813decb26d0b14362dec76a8ff37
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2018-04-08_13:29:47
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Buovjaga 2018-04-22 14:22:37 UTC
I don't get it. Looks the same with "Stretched". Could you attach a screenshot of the badness?
I tested with the coffee beans bitmap.

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: de07f40030bbd604bc42d58f0e954cca284a2646
CPU threads: 8; OS: Linux 4.16; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on April 21st 2018
Comment 2 Telesto 2018-04-23 16:12:30 UTC
1. Format -> Page -> Area tab
2. Bitmap button -> Select a bitmap (style: tiled) 
3. Press Apply (multiple 'tiles' of the same image are added)
4. Check the scale checkbox & Press Apply (no tiles anymore, 1 stretched image) -> the same as style: stretched

Not sure what's intended here, but it's off in my opinion..
Comment 3 Buovjaga 2018-04-23 18:23:25 UTC
(In reply to Telesto from comment #2)
> 1. Format -> Page -> Area tab
> 2. Bitmap button -> Select a bitmap (style: tiled) 
> 3. Press Apply (multiple 'tiles' of the same image are added)

Try zooming to like 600% at this point and compare with the scale/stretched image. It's the same. All bitmaps are "blurred" when you scale them up enough.
Comment 4 Telesto 2018-04-23 18:54:28 UTC
(In reply to Buovjaga from comment #3)
> (In reply to Telesto from comment #2)
> > 1. Format -> Page -> Area tab
> > 2. Bitmap button -> Select a bitmap (style: tiled) 
> > 3. Press Apply (multiple 'tiles' of the same image are added)
> 
> Try zooming to like 600% at this point and compare with the scale/stretched
> image. It's the same. All bitmaps are "blurred" when you scale them up
> enough.

I'm a little confused right know. Yes, zooming in an image will blur things.. 

The confusion is about relative/absolute setting. 
1. Format -> Page -> Area tab
2. Bitmap button -> Select a bitmap (style: tiled) 
3. Press Apply -> Nothing wrong here
4. Check the scale checkbox & Press apply.. A complete different look. I would expect the same results with the initial state of absolute and scale.
Comment 5 Buovjaga 2018-04-23 19:53:50 UTC
(In reply to Telesto from comment #4)
> I'm a little confused right know. Yes, zooming in an image will blur
> things.. 
> 
> The confusion is about relative/absolute setting. 
> 1. Format -> Page -> Area tab
> 2. Bitmap button -> Select a bitmap (style: tiled) 
> 3. Press Apply -> Nothing wrong here
> 4. Check the scale checkbox & Press apply.. A complete different look. I
> would expect the same results with the initial state of absolute and scale.

Hmm, I think the percentage is against the page dimensions. Try setting width and height to 10%, apply and then play around changing the page format (A5, A3...). It seems to stay constantly relative to the page size. You can compare with absolute size.