Bug 116909 - Customize dialog: local help description is wrong (duplicates parent) for many functions
Summary: Customize dialog: local help description is wrong (duplicates parent) for man...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0.2.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HelpGaps-NewFeatures Customize-Dialog
  Show dependency treegraph
 
Reported: 2018-04-09 23:03 UTC by Gerhard Weydt
Modified: 2018-04-17 22:00 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerhard Weydt 2018-04-09 23:03:35 UTC
In the new customize dialog many functions on the left hand display the same description: "Customises and saves current menu layouts as well as creates new menus." This is the case for the zoom functions 150%, 200%, 50% and 75%, for all functions starting with "line", for two of the three functions named "left" and many more.
6.0.3.1 shows the same behavior, although I can only see it in german, for I do not know how to install additional languages using Separate Install GUI.
Version: 6.0.2.1
Build ID: f7f06a8f319e4b62f9bc5095aa112a65d2f3ac89
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: de-DE (de_DE); Calc: group
Comment 1 V Stuart Foote 2018-04-10 00:34:05 UTC
Of course this requires that the locale appropriate Local Help be installed. But confired on Windows 10 Home 64-bit en-US with build specific Local Help and
Version: 6.0.3.2 (x64)
Build ID: 8f48d515416608e3a835360314dac7e47fd0b821
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
Locale: en-US (en_US); Calc: CL


I'd thought this was filed already against bug 80430 but apparently not.

Is there an efficient way to identify what actions have not .xhp article assigned, that would cause fall back to parent description?
Comment 2 Gerhard Weydt 2018-04-10 10:43:30 UTC
Hi Stuart,

there's another meta bug this bug could be connected with. I intended to add it yesterday, but then forgot it. It's
https://bugs.documentfoundation.org/show_bug.cgi?id=103238
If you think it is appropriate and helpful to set the connection to a second meta bug then please do it.

Gerhard
Comment 3 V Stuart Foote 2018-04-10 12:44:28 UTC
(In reply to Gerhard Weydt from comment #2)
Works there as well, added...
Comment 4 Muhammet Kara 2018-04-10 13:17:45 UTC
Showing parent's/duplicate descriptions no longer happens in master. (See bug 116414)

If a description is missing for an item, the description box will be empty. Could you please confirm with the daily build whether this bug is still valid?
Comment 5 V Stuart Foote 2018-04-10 13:27:41 UTC
@Muhammet, thanks for the see also to bug 116494 -- I knew this had just come up in some form. We'll get blanks now for "function" targets with no help description, and a tooltip popup that local help is not installed. So the duplicate description is resolved

https://gerrit.libreoffice.org/#/c/51584/ went in for master/6.1.0

And on Windows 10 Home 64-bit en-US with
Version: 6.1.0.0.alpha0+
Build ID: 818619b0f2f7813decb26d0b14362dec76a8ff37
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2018-04-08_13:29:47
Locale: en-US (en_US); Calc: CL

Confirmed it is working as expected with Cloph's TB62 x86 Windows build [1] including the help pack. 

We could close this, otherwise we can now use the UI to suss out which "functions" have no corresponding .xhp help description and make this a META to track/implement them?

=-ref-=
[1] https://dev-builds.libreoffice.org/daily/master/Win-x86@62-TDF/
Comment 6 Xisco Faulí 2018-04-11 11:09:23 UTC
Closing as per comment 5
Comment 7 V Stuart Foote 2018-04-11 13:04:07 UTC
OK then, back to original scope of wrong descriptions (duplicating of parent function).

And for those functions without descriptions in local help, showing blank, that is a different HelpGaps BZ issue/task.
Comment 8 Gerhard Weydt 2018-04-17 22:00:06 UTC
@Cisco: you say in comment #6, that you are closing, but according to the history you only set resolved.
I have now set verified, because I have done that for
Version: 6.1.0.0.alpha0+
Build ID: 9c4eaa7b81a40d97fe49b85272b40bfeaaf44f86
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-04-16_03:31:36
Locale: de-DE (de_DE); Calc: group
Some of the help texts I noticed as wrong are even not blank now, but contain a correct text.