Bug 116939 - Problem opening excelfile in latest release - due to overflow
Summary: Problem opening excelfile in latest release - due to overflow
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.3.2 release
Hardware: All All
: medium normal
Assignee: Eike Rathke
URL:
Whiteboard: target:6.1.0 target:6.0.5 target:6.0.4
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-11 11:49 UTC by sverre48
Modified: 2018-05-16 15:22 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
The startup/load file error, attached... (32.19 KB, image/png)
2018-04-11 15:45 UTC, sverre48
Details
Prerelease installed - how can it be tested - that's the question (10.63 KB, image/png)
2018-04-30 14:50 UTC, sverre48
Details
File one fails in release 6_1 (26.48 KB, image/png)
2018-04-30 16:58 UTC, sverre48
Details
Same problem when loading file 2 - unsolved... (28.89 KB, image/png)
2018-04-30 16:59 UTC, sverre48
Details
Help about release info 6_1_alpha (53.81 KB, image/png)
2018-04-30 17:01 UTC, sverre48
Details
Still same opening file error/warning in 6.04.2 (20.67 KB, image/png)
2018-05-09 16:07 UTC, sverre48
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sverre48 2018-04-11 11:49:52 UTC
Description:
I share a lot of office files using dropbox by editing both using MS office (at work) and Libreoffice at home. Having installed the latest 6.03 Libreoffice, I get en opening error that seems to be introduced in release 6.03 and of little or noe help with what the problem is and how to resolve it to make it compatible.

Download from link
https://www.dropbox.com/s/jekxf6jgfafzp7q/Asylstr%C3%B8m%2C%202015.xlsx?dl=0

and see yourself. Compatibility across office platforms is very important to assure. Otherwise, I need to scrap my extensive libreoffice usage. The windows platform is win10 (at home) - 64 -bit libreoffice and win7, 64-bit at work

Cheers Sverre
SW development and SW administration

Steps to Reproduce:
1.Just open the windows xslx file from download link (startup warning/error)
2.
3.

Actual Results:  
Startup error...

Expected Results:
Startup error...


Reproducible: Always


User Profile Reset: No



Additional Info:
Resolve the problem reported...


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.181 Safari/537.36
Comment 1 Xavier Van Wijmeersch 2018-04-11 12:49:05 UTC
Saving the file to the native file off libreoffice give me not a warning off exceeding the maximum columns per sheet.
But it will when i open the *.xlsx file format. Anyone ???

Version: 6.0.4.0.0+
Build ID: c6e8460a5b47fa6fa971dde2a89e80662b6e97ae
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); Calc: group
Comment 2 sverre48 2018-04-11 15:45:11 UTC
Created attachment 141289 [details]
The startup/load file error, attached...

...
Comment 3 Xavier Van Wijmeersch 2018-04-11 19:58:52 UTC
duplicate off bug 116274

*** This bug has been marked as a duplicate of bug 116274 ***
Comment 4 sverre48 2018-04-24 08:21:11 UTC
I add another document with this same opening error
https://www.dropbox.com/s/2h8c7cf0fjlx6zr/Trafikkd%C3%B8d%20i%20Norge%2C%201947-2016%2C%20etc.xlsx?dl=0

It is good to have several test files and it happens when edited with Microsoft Office 2010, Excel, and then opening the same xlsx format in Libreoffice/Calc on Windows 10, x64 release of Libreoffice.

It seems to be related to the most recent release, 6.03 - as the same files have been mutually exchanged between Libreoffice Calc and MS Office 2010 (I run win7, 32 bit office, I believe). Maybe this last issue is relevant? 32-bit office of 2010
Comment 5 Eike Rathke 2018-04-27 11:35:37 UTC
Confusing stuff, similar to bug 116274 but there are
<cols><col ... max=1026 .../></cols>
values. It seems Excel is incrementing the last column when saving.
Comment 6 Eike Rathke 2018-04-27 11:36:06 UTC
Taking.
Comment 7 Commit Notification 2018-04-27 14:17:48 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b78ab482911356ef282f7fd40a4509320608a203

Resolves: tdf#116939 cater for the last cols col incremented by Excel

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Eike Rathke 2018-04-27 14:27:34 UTC
Pending review
https://gerrit.libreoffice.org/53565 for 6-0
https://gerrit.libreoffice.org/53566 for 6-0-4
Comment 9 sverre48 2018-04-30 14:43:42 UTC
Newbie question: I have downloaded the latest alpha 6.1.x winx64 release but I still seem to have the official 6.03 available. What is the trick to switch to test the alpha release? I run win10
Comment 10 sverre48 2018-04-30 14:50:52 UTC
Created attachment 141790 [details]
Prerelease installed - how can it be tested - that's the question

Both installations of libreoffice in the programs installed list (win10)
Comment 11 sverre48 2018-04-30 16:57:28 UTC
This release is no good. Both files still produces the same error and why do you not test the alpha release before you ask us to test it. Just follow the requirements described in this bug regarding environment and debug what happens when this error is shown as popup. Yes, files opens but they could be damaged or loss of data and cannot be trusted.

So next time ensure at least releases work for the test data provided before you ask med to test anything.

I upload three negative test (screen shots)
Comment 12 sverre48 2018-04-30 16:58:52 UTC
Created attachment 141795 [details]
File one fails in release 6_1

Same problem exist - fix not working...
Comment 13 sverre48 2018-04-30 16:59:55 UTC
Created attachment 141796 [details]
Same problem when loading file 2 - unsolved...

Same problem exist - fix not working...
Comment 14 sverre48 2018-04-30 17:01:26 UTC
Created attachment 141797 [details]
Help about release info 6_1_alpha

Just to show the prerelease is tested - both drag and drop and File open both produce same sticky error...
Comment 15 Maxim Monastirsky 2018-05-01 00:08:49 UTC
(In reply to sverre48 from comment #14)
> Created attachment 141797 [details]
> Help about release info 6_1_alpha
> 
> Just to show the prerelease is tested - both drag and drop and File open
> both produce same sticky error...
This release was created on 2018-04-25, but the fix was applied on 2018-04-27 (see comment 7), so obviously it doesn't contain the fix. You should try with a more recent build from here: https://dev-builds.libreoffice.org/daily/master/
Comment 16 sverre48 2018-05-02 06:38:28 UTC
Thanks for info. That explains it but I await the next official release (6.1). Any user running windows 10 - should verify that these two calc documents can be opened without this opening warning. So far, I haven't heard of any such experiences.

One reason for not installing the daily build/alpha releases is that I lose the pinned documents after prerelease is installed. See bug
https://bugs.documentfoundation.org/show_bug.cgi?id=117035

And also is afraid to damage documents. However, I will comfirm if okay as soon as official release is published abd works.

Please test (same as above) on win10/x64 release

Download from link
https://www.dropbox.com/s/jekxf6jgfafzp7q/Asylstr%C3%B8m%2C%202015.xlsx?dl=0

https://www.dropbox.com/s/2h8c7cf0fjlx6zr/Trafikkd%C3%B8d%20i%20Norge%2C%201947-2016%2C%20etc.xlsx?dl=0
Comment 17 Commit Notification 2018-05-02 20:42:54 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8a9e5326e77e86de2962ee7569d883091f7fe4c7&h=libreoffice-6-0

Resolves: tdf#116939 cater for the last cols col incremented by Excel

It will be available in 6.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2018-05-02 21:13:15 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-6-0-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=391920065873b3f74efae8c84b8997d27bce49d7&h=libreoffice-6-0-4

Resolves: tdf#116939 cater for the last cols col incremented by Excel

It will be available in 6.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 sverre48 2018-05-09 12:38:36 UTC
I have downloaded the official release of 6.04 for win64 on win10. I suppose this bug is fixed in that release? It would bed good if there was a release info where the bugs resolved were listed. See: https://wiki.documentfoundation.org/ReleaseNotes
Comment 21 sverre48 2018-05-09 16:07:12 UTC
Created attachment 141999 [details]
Still same opening file error/warning in 6.04.2

I have just installed todays published/official 6.0.4 release on win10 x64 platform (as before) and it works for one of the files that experienced the problem but fails with the other one.

So this fix does not work 100% and affected file should be correct (works with MS office/excel 2010, 32 bit)
Comment 22 Eike Rathke 2018-05-14 10:07:48 UTC
The warning for
https://www.dropbox.com/s/2h8c7cf0fjlx6zr/Trafikkd%C3%B8d%20i%20Norge%2C%201947-2016%2C%20etc.xlsx?dl=0
is quite correct, because for sheet '1947-2018,etc' there is

  <cols>
    ...
    <col min="36" max="1035" width="8.42578125" customWidth="1"/>
  </cols>

which means manual/custom column widths have been applied up to column AMU.

We could ignore those definitions altogether.
Comment 23 Commit Notification 2018-05-14 15:15:19 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f72bd4f02b70e1c4855795b4237e2965556c4689

Related: tdf#116939 Disable <cols><col> overflow detection due to excess ...

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 24 Commit Notification 2018-05-16 15:22:16 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a49200d976b8dc0a33d5d1f3a3e52bf2e97828f2&h=libreoffice-6-0

Related: tdf#116939 Disable <cols><col> overflow detection due to excess ...

It will be available in 6.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.