Bug 116952 - EDITING: LibO6.1 does not respond to table dropped from ODB open with earlier version of LibO
Summary: EDITING: LibO6.1 does not respond to table dropped from ODB open with earlier...
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
(earliest affected)
Hardware: All All
: medium normal
Assignee: Not Assigned
Depends on:
Blocks: Database-Firebird-Migration
  Show dependency treegraph
Reported: 2018-04-11 22:49 UTC by Drew Jensen
Modified: 2018-04-17 15:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:

This is the source file after it was also opened under 6.1 (18.14 KB, application/vnd.oasis.opendocument.database)
2018-04-11 22:49 UTC, Drew Jensen
Source file for test - downloaded from the TDF website (970.11 KB, application/vnd.oasis.opendocument.database)
2018-04-14 18:56 UTC, Drew Jensen

Note You need to log in before you can comment on or make changes to this bug.
Description Drew Jensen 2018-04-11 22:49:10 UTC
Created attachment 141292 [details]
This is the source file after it was also opened under 6.1

Attempted to open an ODB with embedded HSQL data which would not finish the migration process to embedded firebird. So, opened the existing ODB in an older version of Libo (5.4x from Ubuntu repo) and drag drop individual tables into a new ODB created with 6.1Alpha (from today's daily build). The 6.1 odb frame does not respond to the dragged table. 

I did the same again but using a copy of LibO 6.0.4 (also from daily builds) as the source, same problem, Libo 6.1 does not respond to the dropped table.

I can open a file in Libo 6.1 (used the attached file, which was created as hsqld under 6.0 and conversted on first open with 6.1) with exisiting tables and sucessfully drag drop individual tables to a fresh ODB, this triggers the dialog expected and finished with a clean import on a couple of test tables. 

To reproduce: open any ODB file with tables in a version of LibO 6.0 or less (with experimental features on) or use any hsql odb with tables.

Start Libo 6.1, create and empty ODB file, drag and drop a table from the source to the target window.

Test machine is Ubuntu 17.10 (vanilla AMD 64bit)
Comment 1 Robert Großkopf 2018-04-12 05:46:39 UTC
Could confirm the buggy behavior.

Have tried this:
Opened an internal HSQLDB with 
Build-ID: 8f48d515416608e3a835360314dac7e47fd0b821
CPU-Threads: 4; BS: Linux 4.4; UI-Render: Standard; VCL: kde4; 

Opened also 
Build-ID: dc823f5fa4a5d2eca56297b9045e5962536c00f9
CPU-Threads: 4; BS: Linux 4.4; UI-Render: Standard; VCL: kde4; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-04-10_23:32:35

Copied a table from LO to No response from 6.1.
Tried with drag and drop. Also no response.
Comment 2 Tamas Bunth 2018-04-14 18:16:48 UTC
This drag and drop thing has nothing to do with the new migration functionality, so it might be a bit confusing to track it under "Database-Firebird-Migration". It is still something interesting in connection with Firebird.

Could you please attach the original file too? So I could see what went wrong with the initial attempt of migration (before the drag-and-drop).
Comment 3 Drew Jensen 2018-04-14 18:56:49 UTC
Created attachment 141358 [details]
Source file for test - downloaded from the TDF website

Changed the summary
The first file I tried as source was an example database found on the TDF website. Attached a copy.
Comment 4 Xisco Faulí 2018-04-17 13:43:36 UTC
As I understand this issue, the problem is when dragging & dropping a table from LibreOffice 6.0 or older to LibreOffice 6.1 but it works OK when dragging & dropping from LibreOffice 6.1 to LibreOffice 6.1.
If my statement is correct, then I would say this is a WONTFIX issue.
it's unlikely end users will have different versions of LibreOffice installed and they will drag&drop tables from one version to the other...
Comment 5 Drew Jensen 2018-04-17 14:48:53 UTC
well, I entered this with a migration tag because for migrating it would make sense. Given that at the time I read the target (libo6.1) would not have the hsqldb engine only fb. It is quite easy to see how this could come in handy IMO.
Comment 6 Xisco Faulí 2018-04-17 15:17:28 UTC
During the last ESC meeting, it was agreed to keep both engines for some more years [1], thus HSQLDB removal was reverted in [2], that's why you see the 'do you want to migrage' dialog in master.
I think it makes sense to close this as RESOLVED WONTFIX. There are more important bugs devs need to fix before 6.1 release...

[1] http://nabble.documentfoundation.org/Libreoffice-qa-minutes-of-ESC-call-tt4237769.html
[2] https://cgit.freedesktop.org/libreoffice/core/commit/?id=f4fc28aedf9c673f368ddc00f3279f6d54c1a654