Bug 116974 - Crash on closing after copying of a table from Impress to Draw
Summary: Crash on closing after copying of a table from Impress to Draw
Status: RESOLVED DUPLICATE of bug 116977
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: AW080-Regressions
  Show dependency treegraph
 
Reported: 2018-04-12 15:29 UTC by Telesto
Modified: 2018-05-10 07:45 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-04-12 15:29:02 UTC
Description:
Crash on closing after copying of a table from Impress to Draw

Steps to Reproduce:
1. Open attachment 141151 [details]
2. Copy the table
3. Open a New Draw document
4. Paste
5. Close the draw document without saving
6. Close Impress

Actual Results:  
Crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.1.0.0.alpha0+
Build ID: 84e2614a75a615d6c8584b13a69b3368d2a12a3d
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-04-12_09:11:38
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Xisco Faulí 2018-04-12 15:39:22 UTC
I can't reproduce it in

Version: 6.1.0.0.alpha0+
Build ID: 24a57e2b854a1b8b3b8533ac72a6614ee29e374a
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

What I see interesting is that if I copy the table to Draw and then I close it, The 'Do you want to save your changes' dialog is not displayed...
Comment 2 Xisco Faulí 2018-04-12 16:39:57 UTC
Trying to reproduce your steps, I reproduced bug 116977, it might be related...
Comment 3 Telesto 2018-04-12 17:23:42 UTC
(In reply to Xisco Faulí from comment #2)
> Trying to reproduce your steps, I reproduced bug 116977, it might be
> related...

The crashing part is bug 116977; sorry for the noise. No save dialog indeed.. lets see what happens after bug 116977

*** This bug has been marked as a duplicate of bug 116977 ***
Comment 4 Xisco Faulí 2018-04-12 17:51:54 UTC
Save dialog problem reported in bug 116978
Comment 5 Telesto 2018-05-10 07:39:55 UTC
*** Bug 117509 has been marked as a duplicate of this bug. ***
Comment 6 Telesto 2018-05-10 07:45:00 UTC
*** Bug 117181 has been marked as a duplicate of this bug. ***