Bug 116991 - document crashes on opening
Summary: document crashes on opening
Status: RESOLVED DUPLICATE of bug 116879
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-13 12:27 UTC by Elmar
Modified: 2018-04-18 21:30 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
riskreg file that crashes (28.39 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-04-13 12:27 UTC, Elmar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Elmar 2018-04-13 12:27:29 UTC
Created attachment 141334 [details]
riskreg file that crashes

Version: 6.1.0.0.alpha0+
Build ID: dc823f5fa4a5d2eca56297b9045e5962536c00f9
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-04-10_23:32:35
Locale: en-GB (en_ZA.UTF-8); Calc: group

I open the attached document.
Select another sheet, click on a cell, and another
Calc crashes

Has no problem in v5.4
Copied config files from a previous DEV save, has no effect
Copied config files from v5.4, has no effect
Comment 1 Xisco Faulí 2018-04-13 13:33:53 UTC
I can't reproduce it in

Version: 6.1.0.0.alpha0+
Build ID: 24a57e2b854a1b8b3b8533ac72a6614ee29e374a
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

My commit is newer than yours.
Could you please try with the latest daily build?
Comment 2 MM 2018-04-14 08:04:04 UTC
Unconfirmed with Version: 6.1.0.0.alpha0+
Build ID: dc823f5fa4a5d2eca56297b9045e5962536c00f9
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-04-10_23:32:35
Locale: en-US (en_US.UTF-8); Calc:
Comment 3 Elmar 2018-04-15 13:04:23 UTC
There is no later version on the build site
https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@70-TDF/
Comment 4 Elmar 2018-04-15 13:16:22 UTC
what is the meaning of the @70?
It has a date in the parent of 14Apr, but the files were saved on 10Apr

and I assume that x86@ is the 32bit version?

I need x86_64@ - 64bit version
Comment 5 raal 2018-04-15 20:30:22 UTC
no crash Version: 6.1.0.0.alpha0+
Build ID: 4ab0912cd214a4b0bdcbcdd2711b831dab9ca60a
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk3;
Comment 6 raal 2018-04-15 20:32:28 UTC
(In reply to Elmar from comment #4)
> what is the meaning of the @70?
it's a buildbot's number
> 
> I need x86_64@ - 64bit version

https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@70-TDF/ is 64 bit

for example here is today build https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86@71-TDF/current/
Comment 7 raal 2018-04-15 20:33:58 UTC
(In reply to raal from comment #6)
> for example here is today build
> https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86@71-TDF/
> current/

sorry,it's 32bit.
Comment 8 Xavier Van Wijmeersch 2018-04-16 10:32:35 UTC
no repro

Version: 6.1.0.0.alpha0+
Build ID: 7d99b161852b4da3b5a2f97efe629d4f7c3a52e9
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); Calc: group
Comment 9 Xisco Faulí 2018-04-16 12:50:52 UTC
Putting to NEEDINFO until Elmar can reproduce it in the latest master build...
Comment 10 Elmar 2018-04-17 07:08:32 UTC
checked using latest build
problem resolved

Version: 6.1.0.0.alpha0+
Build ID: 0f93692fda4226323422cf82ce34ae4bd5e22fab
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-04-16_23:39:49
Locale: en-GB (en_ZA.UTF-8); Calc: group
Comment 11 Xisco Faulí 2018-04-17 08:04:20 UTC
Thanks for retesting with the latest master.
Setting to RESOLVED WORKSFORME as the commit fixing this issue hasn't been identified.
Comment 12 Elmar 2018-04-18 19:06:49 UTC
I am afraid I spoke too soon.

It is crashing again.

I restored to factory settings without effect.

Also tried in safe mode.

Seems to happen when I hover on a cell which has a comment.

Does not do this in v5.4
Comment 13 Xisco Faulí 2018-04-18 21:30:48 UTC
> Seems to happen when I hover on a cell which has a comment.

ah, I see... then we're talking about bug 116879
Closing as DUPLICATED
Thanks!!

*** This bug has been marked as a duplicate of bug 116879 ***