Bug 117001 - cell not readed correctly - Tab as Separator
Summary: cell not readed correctly - Tab as Separator
Status: RESOLVED DUPLICATE of bug 103829
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2018-04-13 20:11 UTC by raal
Modified: 2022-09-12 17:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
test file (7.66 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-04-13 20:12 UTC, raal
Details
printscreen from LO 4.1 (62.17 KB, image/png)
2018-04-14 17:28 UTC, raal
Details
Print screen with 6.0.3 (59.00 KB, image/png)
2018-04-14 20:05 UTC, m.a.riosv
Details
printscreen from LO 3.5 (75.95 KB, image/png)
2018-04-15 05:59 UTC, raal
Details
Screenshot on 4.0.6 (17.75 KB, image/png)
2018-04-15 12:10 UTC, m.a.riosv
Details
Test file (11.04 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-04-15 12:12 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description raal 2018-04-13 20:11:27 UTC
Description:
regression in 4.1. The tab in cell not recognized. 

Steps to Reproduce:
Select A1:A5 on Sheet 'Tab_as_Separator'

Data - Text to Columns

Check that Tab is tagged as separator. Remove the double quote from the Text delimiter selection by erasing the field with backspace or del.

Click Ok


Actual Results:  
values not filled in columns

Expected Results:
values filled into A1:F5


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 raal 2018-04-13 20:12:00 UTC
There are only 'skip'ped commits left to test.
The first bad commit could be any of: 5b8e8eb6da4c81f04b33e3425beaf2e099fcb329 8cb99b3a232f9de0ed0f2f1a4edb0e5e76b2ee81 38fadfd6a71331335d8ddb1c02bc0fe8b7091ffe c9f7c9e138f5d270857d37115b6120bd1f92f518 3e80461a522b76d7cb015a912a1af59c0df4b4c2 8859bfb0c2f89fd4f32172df47e4f256db804637 ad48e158041810ea6da51096efee1d00b21160e9 dd3b98ae34d30ebd5d124f984483f357cff4f95a 76871c18b1da2394e11227b04ae2045de84cfa52 fcc142c6b92b238cd5947370c4a090b15f0d86bd 1c1d85efd661b18073c64d4198ec8d60d9d63281 432f31cce4319bce3a44cb62f591d02fbdde9fb9 00d77e818e990f7b43bcf572bfc48fe965a4f28a acd68030853c503546196136f497e6ea12df2596 152437a36eb603366163e2b5dbc92b18c1dbf21a 973f9b386db4dabff80620b1ac81426016ccfa17 b6ea7786b85877862b4b0926d3c27633e370a5ad d9d9040e492a98fe24be4e6adccdb634f6a06a9a 184de44d59ee106e454c01a2a367c207c4eca7cd 751d7b07faf81cb6928a7872f918ab4645057c2a 15bd98ee7f76be885c9b56cdec900d4a5793e3e4 6c79d008211360facf98a343474950f8e3329d80 a879a3b473eb859c7febfc9a7c99cd4adb2ddfae b2a30aae7072ba073b548831064c7f77291ec964 4f2ce03bc49eba83d7d7431a9382a30efa3ac976 a06be0a4e47e422469aa3b67884ef51e09e88cca 00c4a0e31ab0cb0151da78fbd532feaae18daf80 908107b11de84058d0dec5ff82c813a99c46664b 9a80f7ef705ffb9849f201a9ef746404b031d233 a487a73e3163b7c1b7a2c33b89505b17edc2fd5f 3d89aa2898b354253e6bcd6a50df51ec8ce5eb62 941ae6da8a9b76283681948bfc955f697576a034 c2abfb6a3a458e851ec7584d8fed4517c7dd9f9d c4be6c4b82f2496804466beccb5ac073d137ce68 093706dfb0bdb0d93e34068ca4fe5d2c081eedfa 1a7cdcc72e96c54417f0547b0aee17e9f66306e0 1366d29b14ad1dffdf56bb42794d3765166fa59b bc171efdd585142bad0c12108d975a5683a2822b 2f8c8b638c317349a92e6d2764a845f66428c941
We cannot bisect more!
Comment 2 raal 2018-04-13 20:12:22 UTC
Created attachment 141344 [details]
test file
Comment 3 m.a.riosv 2018-04-14 15:44:23 UTC
Sorry raal but I can't see tab on A1:A5 on Sheet 'Tab_as_Separator'

With a text like:
=1&CHAR(9)&2&CHAR(9)&3
works form me with tab separator.
Comment 4 raal 2018-04-14 17:28:13 UTC
Created attachment 141354 [details]
printscreen from LO 4.1

Hi Miguel, see printscreen from LO 4.1. File is from https://bz.apache.org/ooo/show_bug.cgi?id=4040
Comment 5 m.a.riosv 2018-04-14 20:05:12 UTC
Created attachment 141360 [details]
Print screen with 6.0.3

Opening the file from the original source, I can't see the tabs in. And length of A1 is 6 she number of numbers in the cell, no other characters.

Same result opening with Versión: 4.1.6.2 Id. de compilación: 40ff705089295be5be0aae9b15123f687c05b0a

Maybe I'm missing something.
Comment 6 raal 2018-04-15 05:59:35 UTC
Created attachment 141372 [details]
printscreen from LO 3.5

Could you try older version? I tried it with bibisect version - oldest build, so version can be older.
Comment 7 m.a.riosv 2018-04-15 12:10:07 UTC
Created attachment 141378 [details]
Screenshot on 4.0.6

It shows as you comment with Version 4.0.6.2 (Build ID: 2e2573268451a50806fcd60ae2d9fe01dd0ce24)

So seems it's between 4.0.6 and 4.1.6

Saving with 4.0.6 and opening with a new version like 6.0.3 doesn't solve the issue.
Comment 8 m.a.riosv 2018-04-15 12:12:09 UTC
Created attachment 141379 [details]
Test file

Added a simple test file where to copy cells with tabs created with formula on their value.

Saved with 6.0.3 and opening with 6.0.3 tabs are missing.
Comment 9 m.a.riosv 2018-04-15 12:13:16 UTC
There are data lost so increased the importance.
Comment 10 QA Administrators 2019-04-16 02:53:21 UTC Comment hidden (obsolete)
Comment 11 QA Administrators 2021-04-16 03:56:09 UTC Comment hidden (obsolete, spam)
Comment 12 LeroyG 2022-08-21 14:10:24 UTC
(In reply to m.a.riosv from comment #8)

Menu Data - Text to Columns in B1 works as expected: one number in each column.

After Copy B1, Paste Special (<Ctrl+Shift+V>), press Values Only button, and CHAR(9) is replaced by a Tab space in the cell. But these spaces are seen only in the Input line, not in the cell itself. Notwithstanding, menu Data - Text to Columns works as expected: one number in each column.


Version: 7.2.7.2 (x86) / LibreOffice Community
Build ID: 8d71d29d553c0f7dcbfa38fbfda25ee34cce99a2
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: es-MX (es_MX); UI: en-US
Calc: threaded

Version: 7.4.0.0.alpha1 (x86) / LibreOffice Community
Build ID: b871abad383583f02eb49c7e49aeae01f6941072
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: es-MX (es_MX); UI: es-ES
Calc: threaded

Seen that, the bug Importance must be changed to Normal?
Comment 13 LeroyG 2022-08-21 14:14:23 UTC
After Save and Reload, the Tab spaces in the cell (resulting from paste Values Only) disappear.
Comment 14 Justin L 2022-09-12 17:36:55 UTC
The test file in comment 3 threw me off for a while because the file does NOT open to the tab/sheet that is being discussed.

*** This bug has been marked as a duplicate of bug 103829 ***