Download it now!
Bug 117010 - LibreOffice Impress freezes with some kinds of gifs
Summary: LibreOffice Impress freezes with some kinds of gifs
Status: RESOLVED DUPLICATE of bug 104878
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.0.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL: https://ask.libreoffice.org/en/questi...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-14 15:56 UTC by Dmitry
Modified: 2018-04-17 21:00 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
One-page presentation with gif (1.78 MB, application/vnd.oasis.opendocument.presentation)
2018-04-14 16:02 UTC, Dmitry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry 2018-04-14 15:56:08 UTC
Description:
LibreOffice Impress and LibreOffice Draw freezes after adding of some kinds of animated gif. And then it works fine for a while and then again. The issue appears when the page or slide with the gif is shown on screen.
Some kinds of gifs works as expected.
When demonstration runs (F5) freezings does not appear.
Probably turning off of gif animation in edit mode could temporary solve this problem.

Steps to Reproduce:
1. Create a new presentation or drawing.
2. Insert a gif like the attached one.
3. Wait a little and/or right click on the gif.

Actual Results:  
It freezes for 5-30 seconds then works, then freezes, then works and so on.

Expected Results:
It should work without freezings


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Версия: 6.0.3.2
ID сборки: 8f48d515416608e3a835360314dac7e47fd0b821
Потоков ЦП: 2; ОС:Linux 4.4; Отрисовка ИП: по умолчанию; VCL: gtk2; 
Локаль: ru-RU (en_US.UTF-8); Calc: 


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.81 SputnikBrowser/3.3.2038.2 Safari/537.36
Comment 1 Dmitry 2018-04-14 16:02:33 UTC
Created attachment 141353 [details]
One-page presentation with gif
Comment 2 Dmitry 2018-04-14 16:04:32 UTC
Probably any of big gifs is the cause.
Comment 3 Jean-Baptiste Faure 2018-04-14 19:41:58 UTC
I guess it is the same issue than bug 98500.

Best regards. JBF

*** This bug has been marked as a duplicate of bug 98500 ***
Comment 4 Telesto 2018-04-14 20:02:04 UTC

*** This bug has been marked as a duplicate of bug 104878 ***
Comment 5 Dmitry 2018-04-17 21:00:45 UTC
I think I should say that the difference between this bug and bug #104878 is in CPU usage. My CPU usage is ~33% when LO hungs up. I have amd 250 CPU, 2 cores, 3GHz. Probably it's not a duplicate. 

This issue is present on LO 5.4.6.2 too.