Bug Hunting Session
Bug 117052 - Disable ligatures when letter spacing is used
Summary: Disable ligatures when letter spacing is used
Status: RESOLVED DUPLICATE of bug 66819
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2018-04-16 21:03 UTC by Dominik Kopp
Modified: 2018-04-23 17:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
document with ligatures (40.78 KB, application/vnd.oasis.opendocument.text)
2018-04-16 21:04 UTC, Dominik Kopp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dominik Kopp 2018-04-16 21:03:44 UTC
Description:
When you use fonts like
- Calibiri
- Dejavu Serif
- Source Sans Pro
which support opentype features like ligatures together with spacing then the result looks bad, because letters like ff are without spacing.

Proposal:
Disable ligatures when spacing is used.



Steps to Reproduce:
1. Choose an Opentype font like Calibiri, Dejavu Serif or Source Sans Pro
2. Set letter spacing to 3.0 pt or more
3. Enter an example like "Schriftart" (because of ft)


Actual Results:  
All letters have spacing expect ft

Expected Results:
Space between f and t (=disable ligature)


Reproducible: Always


User Profile Reset: No



Additional Info:
Workaround:
add ":-liga" to the font name to manually disable ligatures.


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 Dominik Kopp 2018-04-16 21:04:44 UTC
Created attachment 141409 [details]
document with ligatures
Comment 2 Dieter Praas 2018-04-17 10:58:32 UTC
Sounds like a duplicate of bug 66819.
Comment 3 Buovjaga 2018-04-22 16:57:44 UTC
(In reply to Dieter Praas from comment #2)
> Sounds like a duplicate of bug 66819.

Dominik: what do you think?
Comment 4 Dominik Kopp 2018-04-23 17:32:14 UTC
it is a duplicate.

*** This bug has been marked as a duplicate of bug 66819 ***