Bug 117064 - Crash on pasting copy from Draw in Calc
Summary: Crash on pasting copy from Draw in Calc
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: AW080-Regressions
  Show dependency treegraph
 
Reported: 2018-04-17 12:27 UTC by Cor Nouws
Modified: 2018-05-28 09:37 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2018-04-17 12:27:57 UTC
[might be in other combinations too .. ]

new Drawing
drag shape, select and copy it
new Calc file
Ctrl+V
   > Crash

found in Version: 6.1.0.0.alpha0+
Build ID: 0f93692fda4226323422cf82ce34ae4bd5e22fab
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-04-16_23:39:49
Locale: nl-NL (nl_NL.UTF-8); Calc: group
Comment 1 Xisco Faulí 2018-04-17 13:49:18 UTC Comment hidden (obsolete)
Comment 2 Xisco Faulí 2018-04-17 14:01:04 UTC
Regression introduced by:

author	Armin Le Grand <Armin.Le.Grand@cib.de (CIB)>	2018-03-01 15:54:32 +0100
committer	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-04-07 00:28:30 +0200
commit	dfefe448c41921f2f1e54d3f69b8b9e89031d055 (patch)
tree	1aace31054b5740e2faffcbc5de66a791be27f7d
parent	eba4d5b2b76cefde90cb3d6638c736f435023a45 (diff)
SOSAW080: Added first bunch of basic changes to helpers

Bisected with: bibisect-linux64-6.1

Adding Cc: to Armin Le Grand
Comment 3 Armin Le Grand 2018-05-09 17:42:40 UTC
@Xisco -> 'drag shape' in description is 'draw shape' ? Or do you do something 'special' really dragging?

When reading as 'draw shape' I cannot reproduce - might be fixed with current fixes. Will need to wait tdf#166993 to be in master...
Comment 4 Armin Le Grand 2018-05-18 11:37:18 UTC
@Xisco: Needinfo, see comment 3
Comment 5 Armin Le Grand 2018-05-21 14:36:02 UTC Comment hidden (obsolete)
Comment 6 Armin Le Grand 2018-05-23 10:18:59 UTC Comment hidden (obsolete)
Comment 7 Xisco Faulí 2018-05-28 09:37:51 UTC
Verified in

Version: 6.1.0.0.beta1+
Build ID: da49f4aeb8d5e9a7d2cba8855d911e7cc1d2f1e2
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

Fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=91b0d2122bdee361bf5412a42d48ff051159cbf2

@Armin, thank you very much for fixing this...