Download it now!
Bug 117088 - FILEOPEN: Some labels in charts are not displayed by default
Summary: FILEOPEN: Some labels in charts are not displayed by default
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: highest normal
Assignee: Tamas Bunth
URL:
Whiteboard: target:7.0.0 target:6.4.2 target:6.3.6
Keywords: bibisected, bisected, regression
: 118109 118778 119733 127396 128799 (view as bug list)
Depends on:
Blocks: Chart-Labels
  Show dependency treegraph
 
Reported: 2018-04-18 14:22 UTC by Xisco Faulí
Modified: 2020-04-09 13:54 UTC (History)
15 users (show)

See Also:
Crash report or crash signature:


Attachments
sample document (2.39 MB, application/vnd.oasis.opendocument.spreadsheet)
2018-04-18 14:22 UTC, Xisco Faulí
Details
Compasion before and after (98.20 KB, image/png)
2018-04-18 14:23 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-04-18 14:22:50 UTC
Created attachment 141464 [details]
sample document

Steps to reproduce:
1. Open attached document
2. Go to 'Invoer' spreadsheet
3. Check Y Axis labels in charts

-> Only 2 labels are displayed per chart instead of 5

Reproduced in

Version: 6.1.0.0.alpha0+
Build ID: 3564b46992fc30e212011c19043a2553178ccbca
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2018-04-18 14:23:39 UTC
Created attachment 141465 [details]
Compasion before and after
Comment 2 Xisco Faulí 2018-04-18 14:24:51 UTC
Regression introduced by:

author	Szymon Kłos <szymon.klos@collabora.com>	2018-03-02 10:39:33 +0100
committer	Szymon Kłos <szymon.klos@collabora.com>	2018-03-04 12:11:09 +0100
commit	35d062f7879d5414334643cb90bff411726b2168 (patch)
tree	9d04dcd4ec3c504b1d6a3e250883e0ce4033d518
parent	0a3151314ad78b86bbb4bd76bac678fbaa9caf06 (diff)
tdf#116163: Limit label height in chart if needed

Bisected with: bibisect-linux64-6.1

Adding Cc: to Szymon Kłos
Comment 3 Xisco Faulí 2018-06-19 13:20:17 UTC
*** Bug 118109 has been marked as a duplicate of this bug. ***
Comment 4 zacgarbage 2018-06-21 09:36:14 UTC
My bug report ([Bug 118109] "Graph axis value markers not displaying correctly") has been closed by Xisco Faulí as being a duplicate of this bug, said to have been resolved. But my bug is not resolved. I have carried out the suggestions ("They are displayed when number format use 2 decimals and date Format use time datas") made by  Jacques Guilleron, but this makes no difference to the incorrectly displayed axes major interval values
Comment 5 Xisco Faulí 2018-07-23 18:49:25 UTC
*** Bug 118109 has been marked as a duplicate of this bug. ***
Comment 6 Jacques Guilleron 2018-07-26 10:07:54 UTC
Hi Xisco,

In Ligger v2.6, Invoer Tab, when reducing Y Axis's font size to 8 in the first chart, to 7 in the second chart, I get all labels displaying. So I guess the issue  comes from charts size reduction.

Jacques
Comment 7 zacgarbage 2018-07-26 13:49:30 UTC
Many thanks for this advice. I have now modified the font size on each of the X and Y axes on all of my graphs.  By trial and error I have managed to select in each case the largest font size that will correctly display the axes' scales.  However in some cases the largest font size that works is 2, which unfortunately renders the scales so small that they are unreadable.  However this partially successful solution surely gives a clue to the experts as to how the bug can be eliminated in its entirety
Comment 8 Szymon Kłos 2018-10-02 07:59:49 UTC
*** Bug 119733 has been marked as a duplicate of this bug. ***
Comment 9 Xisco Faulí 2019-01-01 19:30:01 UTC
Dear Szymon Kłos,
This bug has been in ASSIGNED status for more than 3 months without any
activity. Resetting it to NEW.
Please assigned it back to yourself if you're still working on this.
Comment 10 Xisco Faulí 2019-12-11 15:47:50 UTC
*** Bug 127396 has been marked as a duplicate of this bug. ***
Comment 11 Xisco Faulí 2019-12-11 15:49:07 UTC
*** Bug 118778 has been marked as a duplicate of this bug. ***
Comment 12 Xisco Faulí 2019-12-11 15:52:11 UTC
*** Bug 128799 has been marked as a duplicate of this bug. ***
Comment 13 Xisco Faulí 2019-12-12 12:29:11 UTC
Increasing priority to highest taking into account it's a regression and the number of duplicates is 5 or higher...
Comment 14 Commit Notification 2020-03-09 10:58:11 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7c300296dd727990455449b19b111b9fc49eadad

tdf#131060 tdf#117088 chart view: fix missing or truncated axis labels

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Xisco Faulí 2020-03-10 09:28:38 UTC
Verifeid in

Version: 7.0.0.0.alpha0+
Build ID: a11c10a83f6fceae6cfb519725d06f8eaf1013fb
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@Balazs Varga, thanks for fixing this issue!!
Comment 16 Commit Notification 2020-03-10 10:39:44 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/f10cbeffba8dc52b971bc3f6644eb0cf4bbeb5eb

tdf#131060 tdf#117088 chart view: fix missing or truncated axis labels

It will be available in 6.4.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Timur 2020-03-10 13:46:07 UTC Comment hidden (obsolete)
Comment 18 Xisco Faulí 2020-03-10 13:48:15 UTC
(In reply to Timur from comment #17)
> Balazs, thanks for fixing (if it's Balazs, Assignee is Tamas).
> Xisco, thanks for verifying, but please always make clear you verified also
> all duplicates. 
> I know you do it mostly, but it's better be clear.

yep, i verified them as well
Comment 19 Commit Notification 2020-03-11 15:50:22 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "libreoffice-6-4-2":

https://git.libreoffice.org/core/commit/9253ca68a84130ee3707129fcd25ca3c8262f680

tdf#131060 tdf#117088 chart view: fix missing or truncated axis labels

It will be available in 6.4.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2020-04-09 13:54:36 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/64b15237ab2355a18bb729adaaaa27bc31ad13da

tdf#131060 tdf#117088 chart view: fix missing or truncated axis labels

It will be available in 6.3.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.