Bug 117089 - collapse formulas when printing in right-to-left text
Summary: collapse formulas when printing in right-to-left text
Status: RESOLVED DUPLICATE of bug 115967
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:pdf, regression
Depends on:
Blocks:
 
Reported: 2018-04-18 16:54 UTC by mohammad
Modified: 2018-04-27 14:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
if print the example.odt file, the example.pdf is produced, that formula has been collapsed. (34.32 KB, application/zip)
2018-04-26 11:28 UTC, mohammad
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mohammad 2018-04-18 16:54:07 UTC
Description:
in the right-to-left languages,for example Persian, formulas collapses when converting to PDF format or printing.

Steps to Reproduce:
1.write one sentence in Persian language. 
2. add Formula between the above sentence.
3. export to PDF and look at the result

Actual Results:  
1.write one sentence in Persian language. 
2. add Formula between the above sentence.
3. export to PDF and look at the result

Expected Results:
in the result file, the formula collapsed.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 Jacques Guilleron 2018-04-18 17:14:55 UTC
Hi mohammad,

Can you provide such a Formula in your language? This would be really very kind.
Comment 2 mohammad 2018-04-25 06:53:15 UTC
(In reply to Jacques Guilleron from comment #1)
> Hi mohammad,
> 
> Can you provide such a Formula in your language? This would be really very
> kind.

Hi Jacques
I write Formula in English Language. but when printing ,the formula collapse.
Comment 3 Xisco Faulí 2018-04-26 08:32:24 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)
Comment 4 mohammad 2018-04-26 11:28:33 UTC
Created attachment 141648 [details]
if print the example.odt file, the example.pdf is produced, that formula has been collapsed.
Comment 5 Jacques Guilleron 2018-04-26 12:28:59 UTC
Hi mohammad,

Thank you for the document.
I confirm the collapsed formulas when UI is set to persian and the doc exported to PDF.
Tried with 
LO 6.0.3.2 Build ID: 8f48d515416608e3a835360314dac7e47fd0b821
CPU threads: 2; OS: Windows 6.1; UI render: default; 
Locale: fa-IR (fr_FR); Calc: CL
Comment 6 Xisco Faulí 2018-04-27 14:01:09 UTC
Regression introduced by the same commit as in bug 115967. Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 115967 ***