Bug 117101 - Address Book Data Source Wizard: Default external data source format is dBASE
Summary: Address Book Data Source Wizard: Default external data source format is dBASE
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Gabor Kelemen (allotropia)
URL:
Whiteboard: target:7.0.0
Keywords:
Depends on:
Blocks: Address-Source
  Show dependency treegraph
 
Reported: 2018-04-19 10:58 UTC by Gabor Kelemen (allotropia)
Modified: 2020-06-10 07:29 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of the problem in LO 5.4 (17.29 KB, image/png)
2018-04-19 10:58 UTC, Gabor Kelemen (allotropia)
Details
Same dialog in 6.0.3 (52.90 KB, image/png)
2018-04-19 15:40 UTC, Heiko Tietze
Details
Screenshot with the issue (37.01 KB, image/png)
2018-04-23 06:29 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen (allotropia) 2018-04-19 10:58:46 UTC
Created attachment 141486 [details]
Screenshot of the problem in LO 5.4

1, Start File - Wizards - Address Data Source.
2, Select Other external data source on the first page
3, Push Settings on the second page
4, The Data Source Properties window opens, where you can select the type of the data source to be set up.
The default setting here is dBASE.

I think nowadays dBASE is less used it once was. 
There could be a better default choice, that is more probable to be wanted by users.
My experience is that people usually use this dialog to set up Mail Merge data sources, and for that, they would want to use Spreadsheets. Maybe this could be a  better default than dBASE.
Comment 1 Heiko Tietze 2018-04-19 14:55:19 UTC
needsUXEval requires CC to libreoffice-ux-advise...
Comment 2 Heiko Tietze 2018-04-19 15:40:10 UTC Comment hidden (off-topic)
Comment 3 Gabor Kelemen (allotropia) 2018-04-20 18:08:23 UTC Comment hidden (off-topic)
Comment 4 Julien Nabet 2018-04-20 21:16:01 UTC Comment hidden (off-topic)
Comment 5 Heiko Tietze 2018-04-23 06:29:23 UTC
Created attachment 141553 [details]
Screenshot with the issue

Carefully reading is king. Agree with Spreadsheet for the default.
Comment 6 Thomas Lendo 2018-04-23 18:40:16 UTC
Set to NEW regarding comment 5.
I also vote for Spreadsheet as default format.
Comment 7 Thomas Lendo 2018-04-23 18:42:04 UTC
Set to Enhancement as the current solution is working and not a bug or regression.
Comment 8 Heiko Tietze 2018-05-11 08:40:12 UTC
Likely a very easy hack.
Comment 9 Gabor Kelemen (allotropia) 2020-04-01 23:33:28 UTC
Proposed patch: https://gerrit.libreoffice.org/c/core/+/91541
Comment 10 Commit Notification 2020-04-02 16:54:33 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f16214fc22aa6665bc9667033496f8e4bed80e05

tdf#117101 Make Spreadsheet the default new data source type

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Timur 2020-06-10 07:22:24 UTC
I'll set Verified and this is improvement. 
But I think there should be done more: have all the data sources on the 1st screen / Address Book Type instead of "Other" And "Settings" and dropdown, which are just 3 additional clicks. 

Note: same is for Tools - Address Data Source - Assign