Bug 117111 - CRASH: Copy/pasting a push button from Writer to Calc
Summary: CRASH: Copy/pasting a push button from Writer to Calc
Status: VERIFIED DUPLICATE of bug 116977
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: AW080-Regressions
  Show dependency treegraph
 
Reported: 2018-04-19 16:44 UTC by Telesto
Modified: 2018-05-28 09:41 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
bt with debug symbols (8.52 KB, text/plain)
2018-04-21 06:19 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-04-19 16:44:31 UTC
Description:
Not sure if this worth a report, one out of many similar reports around already ( AW080 related, I think). So might be identical (or not, who knows)

Steps to Reproduce:
1. Open Writer
2. Form -> Pushbutton
3. Copy the push button
4. Open a Calc document -> Paste => Crash

Actual Results:  
Crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.1.0.0.alpha0+
Build ID: 9c4eaa7b81a40d97fe49b85272b40bfeaaf44f86
CPU threads: 4; OS: Windows 6.3; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-04-16_03:31:36
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 MM 2018-04-19 23:18:45 UTC
Unconfirmed on ubuntu 16.04 x64 with Version: 6.0.0.0.alpha1+
Build ID: 637d96a25926e299fff5b4cf5a0055b1d171b23b
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-11-17_23:45:59
Locale: en-US (en_US.UTF-8); Calc: single

Confirmed with Version: 6.1.0.0.alpha0+
Build ID: cc10b063235dcb25ad16f697ea0b1ff91a10bacb
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-04-18_13:21:28
Locale: en-US (en_US.UTF-8); Calc:
Comment 2 MM 2018-04-19 23:29:03 UTC
Doesn't only crash when copying a push button, also with most (all ?) from the form menu, like an option button, a list/combo box or a checkbox.
Comment 3 Xisco Faulí 2018-04-20 09:22:14 UTC
Regression introduced by:

author	Armin Le Grand <Armin.Le.Grand@cib.de (CIB)>	2018-03-01 15:54:32 +0100
committer	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-04-07 00:28:30 +0200
commit	dfefe448c41921f2f1e54d3f69b8b9e89031d055 (patch)
tree	1aace31054b5740e2faffcbc5de66a791be27f7d
parent	eba4d5b2b76cefde90cb3d6638c736f435023a45 (diff)
SOSAW080: Added first bunch of basic changes to helpers

Bisected with: bibisect-linux64-6.1
Comment 4 Julien Nabet 2018-04-21 06:19:15 UTC
Created attachment 141511 [details]
bt with debug symbols
Comment 5 Julien Nabet 2018-04-21 06:21:45 UTC
Noel: noticing your patches about using unique_ptr concerning poolio/itempool/itemset, thought you might be interesting in this one.
Comment 6 Xisco Faulí 2018-05-07 16:46:39 UTC
Adding Cc: to Armin Le Grand
Comment 7 Armin Le Grand 2018-05-09 17:44:42 UTC
Maybe as in tdf#117064: I cannot reproduce - might be fixed with current fixes. Will need to wait tdf#166993 to be in master...
Comment 8 Telesto 2018-05-10 07:48:08 UTC
No repro
Version: 6.1.0.0.alpha1+
Build ID: c5f8a296fcfc08f8ac441cb8300a7565caa50b53
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-05-10_03:01:48
Locale: nl-NL (nl_NL); Calc: CL

*** This bug has been marked as a duplicate of bug 116977 ***