Bug 117130 - Text for selected shape in status bar is broken
Summary: Text for selected shape in status bar is broken
Status: RESOLVED DUPLICATE of bug 116208
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2018-04-20 20:22 UTC by Regina Henschel
Modified: 2018-04-20 21:03 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
File with named shapes on different layers (11.85 KB, application/vnd.oasis.opendocument.graphics)
2018-04-20 20:22 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2018-04-20 20:22:39 UTC
Created attachment 141506 [details]
File with named shapes on different layers

open attached document.
Click on the shapes. (Not clickable shapes belong to the master page.)
Look into the status bar.

Expected:
The name of the layer is shown on the left side next to the page number.
The name of the object is shown in the second field from left.

Observed behavior:
The name of the layer is missing.
The second field from left shows always the text from the first selected object.

It is OK in Version: 6.0.1.1 (x64)
Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
CPU threads: 8; OS: Windows 10.0; UI render: default; 
Locale: de-DE (de_DE); Calc: CL

It is broken in Version: 6.1.0.0.alpha0+ (x64)
Build ID: 55b9706bea5aa9b654ab39bc7d56339422e17087
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-04-18_06:02:46
Locale: de-DE (de_DE); Calc: CL
Comment 1 Telesto 2018-04-20 20:49:50 UTC
Maybe bug 116208 ?
Comment 2 Regina Henschel 2018-04-20 21:03:54 UTC
Indeed. It is related to OpenGL. If I disable OpenGL it works as expected. I'll set it to duplicate, but we need to test it, when bug 116208 is fixed.

*** This bug has been marked as a duplicate of bug 116208 ***